Subscribe

SnapVault via Command Line

I'm trying to setup a simple test w/ SnapVault from my production 3170 (VFiler1) to my 3140 (DRSAN1). I have "sv_ontap_pri" licensed on the 3170 and "sv_ontap_sec" licensed on the 3140. I also have the options "snapvault.access host=all" set on both.

Here is my command:

DRSAN1> snapvault start -S VFiler1:/vol/VMADIN_VOL1/q1 DRSAN1:/vol/VMADMIN_VLT1/q1
Wed Nov 17 14:45:31 EST [DRSAN1: replication.dst.err:error]: SnapVault: destination transfer from VFiler1:/vol/VMADIN_VOL1/q1 to /vol/VMADMIN_VLT1/q1 : source is offline, is restricted, or does not exist.
Transfer aborted: source is offline, is restricted, or does not exist.

Any ideas on what I'm doing wrong? Does the source volume have to be restricted like when initializing a snapmirror? Any help is appreciated.

Thanks!

Re: SnapVault via Command Line

There are a few things you should check:

1) Is snapvault enabled on both arrays?  If not, turn it on.

> options snapvault.enable

2) Can both arrays ping each other via DNS and IP?  This will test networking and DNS resolution (although it appears this isn't the issue).

- If not, fix DNS or add /etc/host entries.

- If resolution is fine, you may have a routing or ACL issue.

Beyond this check this KB article for additional help:

https://now.netapp.com/Knowledgebase/solutionarea.asp?id=kb17076

Re: SnapVault via Command Line

SnapVault is enabled on both filers and they are both on the same network and can communicate with each other. I already have snapmirrors configured between the same filers and these work without an issue.

Here are the messages I get when I try to initiate the transfer: "SnapVault: destination transfer from VFiler1:/vol/VMADIN_VOL1/q1 to /vol/VMADMIN_VLT1/q1 : source is offline, is restricted, or does not exist."

Re: SnapVault via Command Line

Oh, I think I see your problem.  This is the command you are typing per your first post:

DRSAN1> snapvault start -S VFiler1:/vol/VMADIN_VOL1/q1 DRSAN1:/vol/VMADMIN_VLT1/q1

The issue is that you should not be specifying DRSAN1 in the command -- it is already understood that DRSAN1 is your target array because that is where you are attempting to initiate this transfer from.  So, try this instead:

DRSAN1> snapvault start -S VFiler1:/vol/VMADIN_VOL1/q1 /vol/VMADMIN_VLT1/q1