Community

Subscribe
Highlighted

Strange SRA behavior while excuting Reprotect task in Vmware SRM

Anybody can help with Storage Replication Adapter for VMWare SRM. I was successfully failover sites using Vmware SRM + SRA. But when I do reprotect task it fails. When SRM execute SRA functions on my NetAPP console I see following messages:

Tue Aug 12 09:42:22 GMT [riga-na-a:api_mpool_08:warning]: registry: Unexpected error in rollback in regx_commit - Error: No such file or directory (name=options.files.snapmirror.conf.riga-na-a:rdm)

Tue Aug 12 09:42:22 GMT [riga-na-a:api_mpool_04:warning]: registry: Unexpected error in rollback in regx_commit - Error: No such file or directory (name=options.files.snapmirror.conf.riga-na-a:rdm)

Tue Aug 12 09:42:23 GMT [riga-na-a:api_mpool_00:warning]: registry: Unexpected error in rollback in regx_commit - Error: No such file or directory (name=options.files.snapmirror.conf.riga-na-a:rdm)

Tue Aug 12 09:42:24 GMT [riga-na-a:api_mpool_06:warning]: registry: Unexpected error in rollback in regx_commit - Error: No such file or directory (name=options.files.snapmirror.conf.riga-na-a:rdm)

Tue Aug 12 09:42:24 GMT [riga-na-a:api_mpool_02:warning]: registry: Unexpected error in rollback in regx_commit - Error: No such file or directory (name=options.files.snapmirror.conf.riga-na-a:rdm)

Tue Aug 12 09:42:25 GMT [riga-na-a:api_mpool_08:warning]: registry: Unexpected error in rollback in regx_commit - Error: No such file or directory (name=options.files.snapmirror.conf.riga-na-a:rdm)

Tue Aug 12 09:42:26 GMT [riga-na-a:api_mpool_03:warning]: registry: Unexpected error in rollback in regx_commit - Error: No such file or directory (name=options.files.snapmirror.conf.riga-na-a:sqllog)

And this is the message I get from SRA "Error - Failed to reverse replication for failed over devices. SRA command 'prepareReverseReplication' failed. Address of the storage array is not reachable. Storage array might be down or IP address entered might be incorrect. Ensure that the storage array is up and running and the IP address of the storage array is reachable through the command line interface."

Have somebody experienced with behavior. I'm using SRA 2.1.

Thanks in advance.

Re: Strange SRA behavior while excuting Reprotect task in Vmware SRM

I'm having the exact same error during the "Re-protect" operation.    We're you able resolve this problem?

Re: Strange SRA behavior while excuting Reprotect task in Vmware SRM

I am facing same exact issues when I excuting reprotect options. any one have solution to fix this issues?

Re: Strange SRA behavior while excuting Reprotect task in Vmware SRM

[ Edited ]

Hi

 

Refer KB Reprotect operation might fail in SRM 5.x with the error 'SRA command 'discoverDevices' failed' (requires login)

Bug http://mysupport.netapp.com/NOW/cgi-bin/bol?Type=Detail&Display=682694 for 7 mode systems.

http://mysupport.netapp.com/NOW/cgi-bin/bol?Type=Detail&Display=680838 for cluster mode

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.