Subscribe

Thin FlexClone Lun from Thick

Hello.

I have unusual behavior of function clone-start (Creating Flex clone) on 7-Mode.
I have a thick Volume and thick Lun on it. I try to create FlexClone Lun with parameter space-reserve:false (i.e. clone will be thin provisioned) and use temporary snapshot (without existing snapshot). If the lun has used space more than available space on the volume, function has failed with error: "Clone operation failed to start: Volume is full or Volume crossed autodelete threshold..".
For example:
    Volume: 1GB (Available: 300MB), Lun: 700MB (Used: 650MB) - FlexClone doesn't work
    Volume: 1GB (Available: 300MB), Lun: 700MB (Used: 100MB) - FlexClone  works
    
But, If I do this operation and select existing snapshot, it works. Traditional lun clone works too.

What does it mean, what am I doing wrong?

Re: Thin FlexClone Lun from Thick

Hi,

 

Flex clones will not use any additional space, space is required only for the data you write to flex clone.

 

Check how many snapshots are there for the volume, is auto delete of snapshots enabled?

 

Try to create a flex clone with out a snapshot copy creation using -n option

 

Thanks

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Thin FlexClone Lun from Thick

Volume doesn't have a snapshot.

AutoDel snapshot on volume is disabled.

 

Flexclone

al-na-821-7m> clone start /vol/mike_vol/mike_lun /vol/mike_vol/mike_lun_clone -o  
clone start: Volume is full or Volume crossed autodelete threshold

 But Flexclone from snapshot works.

al-na-821-7m> clone start /vol/mike_vol/mike_lun /vol/mike_vol/mike_lun_clone -s snapshot_17 -o                                                                     Clone operation started successfully. ID: 9.

 

Re: Thin FlexClone Lun from Thick

Can you try "-n" instead of "-o"?

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Thin FlexClone Lun from Thick

But it shouldn't work without option "-o" in my case, when source Lun uses space reservation

 

-o : Skip space reservation on the clone when cloning entire file/LUN.
-n : Do not use temporary snapshot for cloning. (Deprecated.)

 

I have tried.

 

al-na-821-7m> clone start /vol/mike_vol/mike_lun /vol/mike_vol/mike_lun_clone -n
clone start: Volume is full or Volume crossed autodelete threshold..
al-na-821-7m> clone start /vol/mike_vol/mike_lun /vol/mike_vol/mike_lun_clone1 -n -s snapshot_17 clone start: Volume is full or Volume crossed autodelete threshold..