Community

Subscribe
Highlighted

Unable to change permissions (chmod 4710)

Running NetApp Release 8.0.2 7-Mode on a FAS 2040

I have a RH Linux 5 environment setup and I'm trying to change permissions on a particular file using chmod 4710 but it only changes it to 710.  If I move the file over to the local file system it changes just fine.

-rwx--x--- 1 applmgr dba 28122 Apr 21  2012 nmb

what I need is this -

-rws--x--- 1 applmgr dba 28122 Apr 21  2012 nmb

Ideas or suggestions? 

Thanks!

Re: Unable to change permissions (chmod 4710)

Is the volume shared or mounted with nosuid?  Is the volume acl unix?

Bill

Re: Unable to change permissions (chmod 4710)

The volume is mounted, not sure if nosuid is in effect - how can I check?  The volume is acl unix.

Thanks.

Re: Unable to change permissions (chmod 4710)

On the linux side, run the mount command, and look for your mount point.  Under the options it will list nosuid if in effect.  You can also check /etc/fstab so see what options it's mounted with.

The the filer side, check /etc/exports, and see what options the volume is exported with - if nosuid is there, that is the problem.

Bill

Re: Unable to change permissions (chmod 4710)

Thanks Bill for your input.  This is what I have on the /etc/fstab on the linux box -

na02:/vol/db_top /u01/oracle/proddb nfs rsize=32768,wsize=32768,hard,nointr,rw,bg,vers=3,tcp,actimeo=0,timeo=600

I'm assuming in order to see the /etc/exports on the filer I'll need to mount the vol0?

Re: Unable to change permissions (chmod 4710)

You can mount vol0, or log in and "rdfile /etc/exports", or "exportfs -q /vol/db_top" (exportfs -q I have not used in practice before - but it looks like it mirrors the exports line).

Bill