Subscribe

Unable to get Netapp Cluster 9.1 cluster, node and aggregate related data

[ Edited ]

I am getting following errors while getting cluster, node, aggregate, lun and user roles related data.

 

Device OS Version is :  NetApp Release 9.1

 

com.netapp.nmsdk.ApiExecutionException: Unable to find API: cluster-identity-get
        at com.netapp.nmsdk.client.ApiRunner.run(ApiRunner.java:141)
        at com.netapp.nmsdk.client.ApiRunner.run(ApiRunner.java:105)
        at cluster.TestNetappCluster.go(Unknown Source)
        at cluster.TestNetappCluster.main(Unknown Source)
com.netapp.nmsdk.ApiExecutionException: Unable to find API: system-node-get-iter
        at com.netapp.nmsdk.client.ApiRunner.run(ApiRunner.java:141)
        at com.netapp.nmsdk.client.ApiRunner.run(ApiRunner.java:105)
        at cluster.TestNetappCluster.go(Unknown Source)
        at cluster.TestNetappCluster.main(Unknown Source)
com.netapp.nmsdk.ApiExecutionException: Unable to find API: cluster-peer-health-info-get-iter
        at com.netapp.nmsdk.client.ApiRunner.run(ApiRunner.java:141)
        at com.netapp.nmsdk.client.ApiRunner.run(ApiRunner.java:105)
        at cluster.TestNetappCluster.go(Unknown Source)
        at cluster.TestNetappCluster.main(Unknown Source)
com.netapp.nmsdk.ApiExecutionException: Unable to find API: aggr-get-iter
        at com.netapp.nmsdk.client.ApiRunner.run(ApiRunner.java:141)
        at com.netapp.nmsdk.client.ApiRunner.run(ApiRunner.java:105)
        at cluster.TestNetappCluster.go(Unknown Source)
        at cluster.TestNetappCluster.main(Unknown Source)
com.netapp.nmsdk.ApiExecutionException: Unable to find API: aggr-list-info
        at com.netapp.nmsdk.client.ApiRunner.run(ApiRunner.java:141)
        at com.netapp.nmsdk.client.ApiRunner.run(ApiRunner.java:105)
        at cluster.TestNetappCluster.go(Unknown Source)
        at cluster.TestNetappCluster.main(Unknown Source)
com.netapp.nmsdk.ApiExecutionException: Unable to find API: lun-list-info
        at com.netapp.nmsdk.client.ApiRunner.run(ApiRunner.java:141)
        at com.netapp.nmsdk.client.ApiRunner.run(ApiRunner.java:105)
        at cluster.TestNetappCluster.go(Unknown Source)
        at cluster.TestNetappCluster.main(Unknown Source)

com.netapp.nmsdk.ApiExecutionException: Unable to find API: security-login-get-iter
        at com.netapp.nmsdk.client.ApiRunner.run(ApiRunner.java:141)
        at com.netapp.nmsdk.client.ApiRunner.run(ApiRunner.java:105)
        at filer.Cluster.go(Unknown Source)
        at filer.Cluster.main(Unknown Source)

 

Is there any configuration I need to change?

 

Kindly help me.

 

Thanks

 

 

Re: Unable to get Netapp Cluster 9.1 cluster, node and aggregate related data

not sure if this helps

https://mysupport.netapp.com/documentation/docweb/index.html?productID=62339&language=en-US

thanks

Jeff

Cannot find the answer you need?  No need to open a support case - just CHAT and we’ll handle it for you.