Subscribe

VSCAN on 7-mode for vfilers

Hi all, below is how we have set up our vscan per vfiler:

 

robvfiler@filer1> vscan

Virus scanning is enabled.

This vfiler is configured to use vscan servers connected to the host filer.

Secondary scanners IP address list:
10.105.130.101,10.105.130.102,10.105.130.103

 

robvfiler@filer1> vscan options
vscan options timeout:          10 sec
vscan options abort_timeout:    10000 sec
vscan options mandatory_scan    on
vscan options use_host_scanners on
vscan options client_msgbox     off

 

we aere advised that   with this 'on': vscan options mandatory_scan    on

 

All our vfilers would use vfiler0 as a gateway so causing performance issues.

 

However, after turning it off - I don't have any scanners attached

 

vscan options use_host_scanners off

 

robvfiler@filer1> vscan

Virus scanning is enabled.

 

No vscan servers are connected.

Secondary scanners IP address list:
10.105.130.101,10.105.130.102,10.105.130.103

 

 

I don't see a way to add primary scanner to a vfilers - synatax below. Can anyone help?   thanks Rob

 

 

 

vscan scanners [stop scanner-IP-address | secondary_scanners [ scanner-IP-address [,  scanner-IP-address ]]]

 

 

 

 

 

 

Re: VSCAN on 7-mode for vfilers

First, let me give you some advice.  NEVER EVER EVER NEVER EVER NEVER use mandatory scan on.   You are asking for problems.

 

 

Also, your abort timeout is set wrong.  It should be 40seconds and you should work with your a/v team to confirm theirs is 50seconds.  

 

Also, we only configure the vscan at the host layer and then refence the option below

vscan options use_host_scanners on

 

 

Re: VSCAN on 7-mode for vfilers

Hi, mandatory scan is actually off for for our production vfilers - this vfiler is not in use but thanks.

 

I will also check the abort timeout - again inherited - thanks.

 

 

However, does anyone know of a way to configure vfilers to use vscan scanners directly?

Support advised that using them at the host level (vscan options use_host_scanners on) was a bottleneck through vfiler0.

 

 

thanks ..