Subscribe
Accepted Solution

VTIC Showing up first in the order in 'igroup show' output

Hi All,

A relatively simple question I am hoping someone can answer definitively.

For many years  I have been under the impression that when you run 'igroup show' the first entry listed is the primary path that is in use. I am not sure if this has changed now with the advent of ALUA, or if it never was the case.

eg In this example below (this is an ALUA igroup) the vtic entry appears first, then 0a/0b and therefore by my reckoning would be the primary path that is in use -

viaRPC.xx:xx:xx:xx:xx:xx:xx:xx.xxx-xxxxxxx (FCP) (ostype: windows):

        xx:xx:xx:xx:xx:xx:xx:xx (logged in on: vtic, 0b)

viaRPC.xx:xx:xx:xx:xx:xx:xx:xx.xxx-xxxxxxx (FCP) (ostype: windows):

        xx:xx:xx:xx:xx:xx:xx:xx (logged in on: vtic, 0a)

   

The reason I am questioning this (as well as my sanity) is that looking on the zoning info, and in Netapp DSM 3.4 on the Windows 2008R2 host after the reboot the paths seem to be correct with Active/Optimized* set on the correct paths. There were some initial Partner I/O traffic present but after I reset the lun stats with lun stats -z then checked again all looks fine (no partner traffic) and lun config_check -v shows no problems.

I found this communities post -

https://communities.netapp.com/message/51158

As touched on by Riley Welshman on 28-Mar-2011 11:08 in the above post he says as far as he is aware it does not matter what order the paths are displayed as long as the paths are correct and obviously you are not seeing increasing counts of Partner I/O on lun stats -o

My question is simply is this correct? - am I mistaken?.

All contributions welcome.

Re: VTIC Showing up first in the order in 'igroup show' output

Well I can happily confirm I was wrong -

https://kb.netapp.com/support/index?page=content&id=3011742