Subscribe
Accepted Solution

What is "autodelete_base" snapshot on aggr0 and how to disable it?

Hello colleagues,

could anybody explain what is purpose of "autodelete_base" snapshot in aggr0 and how to remove it permanently?

As I noticed, snap_autodelete is permanently turn ON in DOT 8.2.x 7mode. And only way, how to disable this snapshot is to set aggr snap reserve to 0.

Is there any other solution? I noticed those only on single systems, HA pairs, but not on metrocluster gateway filer with syncmirror aggregates.

 

Thanks in advance for feedback.

 

Regards

Petr Jaros

Re: What is "autodelete_base" snapshot on aggr0 and how to disable it?

I've seen this when aggr snapshots are autodeleted for no space... If you set the snapshot schedule to 0 "snap sched-A aggrname 0" and the reserve to 0 "snap reserve -A aggrname 0", then run "snap delete -A aggrname autodelete_base" does it go away?

Re: What is "autodelete_base" snapshot on aggr0 and how to disable it?

The purpose of “Autodelete_base”  is : If Aggregate snapshot autodelete is leaving you with no snapshots, the storage system will automatically create a snapshot called autodelete_base at the aggregate level when a snapshot is removed as a result of autodeletion. This ensures that there is always a new snapshot in the aggregate after a snapshot is deleted.

If aggregate snapshots are enabled and there is not adequate space reserved for these snapshots, a situation may develop where a very large aggregate snapshot is created. This may occur if large volumes are deleted.If SyncMirror triggers an aggregate level snapshot and there is not enough space for two snapshots, the existing snapshot is deleted by the autodeletion feature and instantly replaced by the autodelete_base snapshot. However, there is still not enough space for the SyncMirror triggered snapshot. This will cause a loop of autodeletion which can only be interrupted by manually deleting the autodelete_base snapshot.

Steps

  1. Disable automatic aggregate Snapshot copy creation by entering the following command:aggr options aggr_name nosnap on

aggr_name is the name of the aggregate for which you want to disable automatic Snapshot copy creation.

  1. Delete all Snapshot copies in the aggregate by entering the following command:snap delete -A -a aggr_name
  2. Set the aggregate Snapshot reserve to 0 percent by entering the following command:snap reserve -A aggr_name 0
If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: What is "autodelete_base" snapshot on aggr0 and how to disable it?

Thank you for the explanation. This works.