Subscribe
Accepted Solution

Where is this IP address coming from?

[ Edited ]

I opened a support case about this, but it just keeps going around in circles.  

 

I recently attempted to download an OnTap update from our internal HTTP server for our AFF8040, and the address that the NetApp was coming in as is 172.22.19.23 which isn't assigned to anything that I can find on the filer. (The same exact thing is happening on our other cluster in a different data center with different IPs)

 

                 On the filer, e0M has a MAC address of “00:a0:98:a2:2f:b3”

 

Oriole::> network port show -node Oriole-01 -port e0M

 

                                        Node: Oriole-01

                                        Port: e0M

                                        Link: up

                                         MTU: 1500

             Auto-Negotiation Administrative: true

                Auto-Negotiation Operational: true

                  Duplex Mode Administrative: auto

                     Duplex Mode Operational: full

                        Speed Administrative: auto

                           Speed Operational: 1000

                 Flow Control Administrative: full

                    Flow Control Operational: full

                                 MAC Address: 00:a0:98:a2:2f:b3

 

 

                On the switch, there are a number of ARP entries all related to that MAC address on Port 2:11. 

 

Destination      Mac                         Age  Static  VLAN                            VID   Port

172.22.16.5      00:a0:98:a2:2f:b3    7      NO  Internal_Appliances  16    2:11

172.22.16.7      00:a0:98:a2:2f:b3    4      NO  Internal_Appliances  16    2:11

172.22.19.23     00:a0:98:a2:2f:b3    1      NO  Internal_Appliances  16    2:11

 

                The first two addresses as statically assigned on the filer:

 

Oriole::> network interface show

            Logical    Status     Network            Current       Current Is

Vserver     Interface  Admin/Oper Address/Mask       Node          Port    Home

----------- ---------- ---------- ------------------ ------------- ------- ----

Oriole

            Oriole-01_mgmt up/up    172.22.16.5/20     Oriole-01     e0M     true

              cluster_mgmt up/up    172.22.16.7/20     Oriole-01     e0M     true

 

 

                172.22.19.23 is clearly being sent by something on the NetApp side as that address is shown to have the same MAC address as 172.22.16.5, 172.22.16.7 (both of those IPs are assigned to e0m) but what is it?  

Re: Where is this IP address coming from?

Hi

 

Did you upgrade to ONTAP 9.3?

 

I guess that problem Bug ID#1142938

 

Bug Detail

 

Bug ID 1142938
Title The DHCP IP address for the e0M interface is not removed after installing ONTAP 9.3
Duplicate of  
Bug Severity 2 - System barely usable
Bug Status Not Fixed
Product Data ONTAP
Bug Type Unknown 
Description
Formatted
 When you perform a fresh installation of ONTAP 9.3, and the boot environment 
 variable "bootarg.init.dhcp.disableb is either undefined or set to "false", the 
 e0M management interface attempts to automatically obtain an IP address during 
 the boot process.
 
 As a result, if the storage system can access a Dynamic Host Confiuration 
 Protocol (DHCP) server, the system obtains an additional IP address for the 
 e0M interface. This DHCP IP address might be removed during the cluster setup 
 process when configuring a static IP address. However, DHCP requests to obtain 
 IP addresses continue at every reboot and the DHCP IP address might again be 
 configured on the e0M interface when the reboot process completes. The 
 DHCP-assigned IP address remains active on the e0M interface until you set 
 the "bootarg.init.dhcp.disableb variable to "true" and the system is rebooted.
 
Workaround
Formatted
 Contact technical support for assistance.
  
Notes
Formatted
 None
 
Fixed-In Version  A complete list of releases where this bug is fixed is available here.
Related Bugs  

Re: Where is this IP address coming from?

That is exactly what the problem is.  We upgraded from 9.2 P1 to 9.3 P1.  I will keep waiting for a fix.  Thanks!