Community

Subscribe
Highlighted

network ping with jumbo frames does not work

I believe the network ping command in cDOT does not work with jumbo frames.  I have verified on two systems with jumbo frames that work fine from the ESX host but when I do it from the filer it does not work. 

Example:

network ping -lif-owner [svm] -lif [nfs_lif] -destination [esx host nfs IP] -show-detail -disallow-fragmentation true -packet-size 8000

It returns back "ping: sendto: Message too long"

Though if I do a ping from the esx host ping -d -s 8000 [nfs_lif] it works as expected.  Also the switch shows TX and RX jumbo frames. 

Does the command not support a packet size over 1472?

Re: network ping with jumbo frames does not work

Jason -

How very interesting, given that 'cluster ping-cluster' uses 1500, 4500, and 9000 sized frames to test the cluster network.

Also, given that 'network ping' has the '-packet-size' option to it.

This is one I might have to try out in my lab environ ...

I hope this response has been helpful to you.

At your service,

Eugene E. Kashpureff, Sr.

Independent NetApp Consultant, K&H Research http://www.linkedin.com/in/eugenekashpureff

Senior NetApp Instructor, IT Learning Solutions http://sg.itls.asia/netapp

(P.S. I appreciate points for helpful or correct answers.)

Re: network ping with jumbo frames does not work

Yes, cluster ping works great. Very strange.

-Jason

Re: network ping with jumbo frames does not work

Jason -

Still haven't fired off the lab environ yet, but did you try advanced priv ?

(like with the -flood option)

Historically, NetApp tries to avoid letting you do abusive things to the network.

This might be one of those cases.

I'm very interested to work this one out, given that it's one of those tidbits that I can add to lecture in classes !

I hope this response has been helpful to you.

At your service,

Eugene E. Kashpureff, Sr.

Independent NetApp Consultant, K&H Research http://www.linkedin.com/in/eugenekashpureff

Senior NetApp Instructor, IT Learning Solutions http://sg.itls.asia/netapp

(P.S. I appreciate points for helpful or correct answers.)

Re: network ping with jumbo frames does not work

I haven't tried the -flood option but I don't see how that would help.  

Re: network ping with jumbo frames does not work

Jason -

I was suggesting you try using advanced priv to run the command.

I'm teaching Cluster Mode Performance in Brisbane, Australia this week.

We used this as an exercise in class today.

It does work in advanced priv:

cluster1:Smiley Embarassedset -privilege advanced

cluster1::*>network ping -lif-owner vs2 -lif vs2_cifs_nfs_lif1 -destination 192.168.0.10 -disallow-fragmentation true -packet-size 9000

no answer from 192.168.0.10

cluster1::*>set -privilege admin

cluster1:Smiley Embarassed

I hope this response has been helpful to you.

At your service,

Eugene E. Kashpureff, Sr.

Independent NetApp Consultant, K&H Research http://www.linkedin.com/in/eugenekashpureff

Senior NetApp Instructor, IT Learning Solutions http://sg.itls.asia/netapp

(P.S. I appreciate points for helpful or correct answers.)