Subscribe
Accepted Solution

problems installing from dvadmin

[ Edited ]

Hi, I have been having problems while trying to install ONTAP Edge from dvadmin

 

I have installed the Data ONTAP-v Installer (from 821RC2_121_v_installer.ova) and get an error when running the setup wizard

 

Error encountered while creating VM

[13] InvalidArg: vm invalid - Virtual machine argument is invalid or missing

[81] VmCreateOvfErr: Cannot create VM 'node1'

 

Any ideas what could be causing this?

It seems to have picked up the VM Name ('node1') enough to fill in the second line of the error

Re: problems installing from dvadmin

Hi Mike,

Would it be possible for you to post a screenshot and describe some more steps on how you hit this problem

-Srinivas

Re: problems installing from dvadmin

Re: problems installing from dvadmin

Thanks Mike for the screenshots.

I do see the error message clearly in pics

few more things.

a) Which VC / ESX version is being used here to deploy Data ONTAP-v Installer .ova

b) Does VC/ESX throw some warning / error messages in the VI client page.

-Srinivas

Re: problems installing from dvadmin

The installer is deployed on ESXi, 5.1.0, 1065491 (5.1 update 1) and I am attempting to create a VM on the same host

I get no warnings in the vSphere window, it gives me a few recent tasks logged while configuring the options:

"Find entity by IP" *2

"Refresh storage information" *

Nothing comes up after it starts creating the VM

Is the vm argument mentioned in the error one of the user supplied arguments or is this one hidden in the OVF package that is being deployed?

Re: problems installing from dvadmin

Sorted it out

The problem was caused by VM license restrictions preventing dvadmin from running properly

the hostd.log was reporting multiple instances of:

--> (vim.fault.RestrictedVersion) {

-->    dynamicType = <unset>,

-->    faultCause = (vmodl.MethodFault) null,

-->    msg = "",

--> }

This was because I had installed a free ESXi license on the test server by mistake