Subscribe
Accepted Solution

sdcli disabling lun reservation during disk create

Hi all

is there a way to disable the LUN space reservation during the disk create command?

Or in other words: what is the corresponding option in sdcli to >lun set reservation <path> disable?

I thought this is disk create  ... -rs y/n, but it isn't.

thx

Mark

Re: sdcli disabling lun reservation during disk create

There is no such option in the “disk create” command.

Instead, you can use the storacl.exe utility to achieve this one.

With storacl.exe, you can set the volumes as either ThinProvision on/off.

If on, the luns that get created will be thin provisioned for that particular volume.

Or, there is the sdparams.conf file that can be used to achieve the same.

Thanks,

~Satish

Re: sdcli disabling lun reservation during disk create

Re: sdcli disabling lun reservation during disk create

Thanks for the help.

Personally I think it is a pitty that there is no built-in option and one has to use the rather hard-to-understand tool storacl.

but nevermind. Since I was looking for it for a scripted solution and there is access to the storage, I'd rather call lun set reservation directly.

Mark