Subscribe

snap autodelete on volume not deleting

[ Edited ]

Let me start off by saying that i'm new to storage and am learning as I go.  We have a netapp NAS that has 5 volumes and one of the volumes "datastore0" has nightly snapshot copies that run nightly on it.  What we have been doing is manually deleting old snapshots as the volume space is increased.  I've enabled snapshot autodelete however old snapshots are not autodeleting.  Below are my settings and I can't seem to figure out why it's not autodeleting.

 

drmnetapp1a> snap autodelete datastore0 show
snapshot autodelete settings for datastore0:
state : on
commitment : try
trigger : volume
target_free_space : 15%
delete_order : oldest_first
defer_delete : none
prefix : (not specified)
destroy_list : none

 

Here are my volumes and sizes.

 

drmnetapp1a> df -h
Filesystem total used avail capacity Mounted on
/vol/vol0/ 153GB 4202MB 149GB 3% /vol/vol0/
/vol/vol0/.snapshot 8294MB 250MB 8043MB 3% /vol/vol0/.snapshot
/vol/datastore0/ 3072GB 2421GB 320GB 90% /vol/datastore0/
/vol/datastore0/.snapshot 0GB 414GB 0GB ---% /vol/datastore0/.snapshot
/vol/shares0/ 2048GB 398GB 320GB 84% /vol/shares0/
/vol/shares0/.snapshot 0GB 22GB 0GB ---% /vol/shares0/.snapshot
/vol/non_replicated/ 2048GB 9982MB 320GB 84% /vol/non_replicated/
/vol/non_replicated/.snapshot 0TB 0TB 0TB ---% /vol/non_replicated/.snapshot
/vol/backups/ 1024GB 544GB 320GB 69% /vol/backups/
/vol/backups/.snapshot 0TB 0TB 0TB ---% /vol/backups/.snapshot

 

Any help is appreciated.