Subscribe

snapshot-list-info hangs

[ Edited ]

Hi all

Running the SDK (using 4.1) command 'snapshot-list-info' on some volumes (always the same ones) either hangs forever or returns the following error after some time:

'<results reason="Cannot get snapshot list info" status="failed" errno="13001"/>'

 

I tested it with Perl (on linux) and with the NetApp provided tool ZExplore (on Windows), so it doesn't seem to be a language spec. problem. I used the following snippet in ZExplore:

<?xml version="1.0" encoding="UTF-8"?>

 

<netapp xmlns="http://www.netapp.com/filer/admin" version="1.13">

  <snapshot-list-info>

    <target-name>testVol1</target-name>

    <target-type>volume</target-type>

  </snapshot-list-info>

</netapp>

 

Running 'snap list' on the same volume - even while the SDK command hangs - works as it should.

 

The error is reproducible always on the same volumes. snapshot-list-info on other volumes and/or on the same filers runs without a problem.

 

Thanks for helping and regards

Janosch

rle Former NetApp Employee

Re: snapshot-list-info hangs

Janosch -

What version of the DataONTAP are you running?

Regards,

   - Rick -

Re: snapshot-list-info hangs

Sorry for the late response! We're using the version 8.0.2P2 in 7-mode.

rle Former NetApp Employee

Re: snapshot-list-info hangs

Janosch -

Try setting terse to true.

<?xml version="1.0" encoding="UTF-8"?>

<netapp xmlns="http://www.netapp.com/filer/admin" version="1.13">

  <snapshot-list-info>

    <target-name>testVol1</target-name>

    <target-type>volume</target-type>

    <terse>true</terse>

  </snapshot-list-info>

</netapp>

Regards,

   - Rick -

Re: snapshot-list-info hangs

Rick,

It works with terse, but then the used size is omitted. That's actually what I'm looking for. If there is another way to get the used size of all snapshots of a volume I'd be happy as well!

Regards,

Janosch

rle Former NetApp Employee

Re: snapshot-list-info hangs

Janosch -

Are there more snapshots on the volumes that are not responding than the volumes that are responding?

Regards,

   - Rick -

Re: snapshot-list-info hangs

Hi Rick

Do you ask if there are more volumes responding than not? If so: no, from about 80% of all volumes (hundreds) on all filers I get a response.

Regards

Janosch

rle Former NetApp Employee

Re: snapshot-list-info hangs

Hi Janosch -

That's great that 80% of all the volumes are responding.  I'm trying to figure out why some of the volumes are not responding to returning total and cumulative-total.  Are these unresponsive volumes in a restricted or offline state, are they in a SnapMirror of SnapVault transfer, or do they have a lot more snapshots than the succeeding volumes?

Regards,

   - Rick -

Re: snapshot-list-info hangs

Hi Rick

Unfortunately I have to answer no to all of your questions, their neither restricted nor offline, not in SnapMirror or SnapVault transfer (it also occurs on source vols) and they have as many snapshots as the other volumes. I got a sample volume for you:

vol status renamedVol

         Volume State           Status            Options

renamedVol online          raid_dp, flex     create_ucode=on,

                                                  convert_ucode=on

                         Volume UUID: c321ff2c-6207-11df-96d7-00aaaa000bb

                Containing aggregate: 'renamedAggr'

                        Volinfo mode: 7-mode

Thanks,

Janosch

rle Former NetApp Employee

Re: snapshot-list-info hangs

Hi Janosch -

Sorry, I'm out of ideas for the moment.  Please attach snap list, and I will ask around.

Regards,

   - Rick -