Subscribe

unable to set volume attribute "min-autosize" for volume

We have a TDP volume(destination), that is in snapmirrored state from 7Mode to cDOT.

While trying to resize/increment the volume size by say 100g we get the following error.

 

clusterName> volume size volumneName -vserver vserverName +100g

Warning: Volume "vserver:volumeName" is a SnapMirror destination volume. The Filesystem Size for this volume is derived from its source and cannot be changed. The specified size will be used as the Volume Size.
Do you want to continue? {y|n}: y

 

Error setting size of volume "vserver:volumeName". Unable to set volume attribute "min-autosize" for volume
"volumeName" on Vserver "vserverName". Reason: Volume 'volumenName' is a snapmirrored volume.
vol size: Flexible volume 'volumeName' size limit set to 8022664413184.

 

 

Any idea ? 

 

Volumes autosize mode is false.

Re: unable to set volume attribute "min-autosize" for volume

In a snapmirrored state you cannot change the setting.

 

Did you not get this error message when you tried

 


Warning: Volume "filer:volume" is a SnapMirror destination volume. The Filesystem Size for this volume is derived from its
source and cannot be changed. The specified size will be used as the Volume Size.

 

I just ran this in my lab.  I'm running 8.3.1rc1

Re: unable to set volume attribute "min-autosize" for volume

Hi 

   I am not trying to change any setting. I am trying to increase the size of the volume. I understand in case of a Snapmirrored volume the fs_fixed options is ON.

But one can always increase the actual volume size using vol size command.

 

Even if I increase the size on ONTAP on the file system side it will show as the size same as source. I understand that.

 

So my question is why is it prevenitng me from increasing the size.

 

Regards

Adai