Subscribe

vfiler setup issue

Hii, There is a node fdlr whose ip starts with 172.31 serving to JD domain..and I have to setup a new vfiler to serve data for another domain called Nor domain (192.168).

There is an existing  vif1 (where e0a is up, e0a is down) which is used as filer interface. So I have created a vlan 400 serving for vfiler, so I created vlan, ipspace,assigned vif1-400 to ipspace, created vfiler, assigned the vfiler ip to vlan 400 by ifconfig and then did default route from vfiler to the gateway of switch.

After the above creation process, vfiler was able to talk to Nor-domain switch or gateway, filer wasnt able to talk to JD domain switch, and the server team were not able to access there CIFS shares from the filer before I want to setup cifs for vfiler.

So was wondering what might be the issue. Hope anyone assists me on this

Vif1– original ip of the fdlr filer (JD domain)

Vif1-400- vfiler vlan (Nor-domain)

Thanks,

Karthik

Re: vfiler setup issue

Are you on ONTAP 8?  Prior to ONTAP 8 if you have a VLAN you can't assign an ip to the base interface...that changed with 8.x though.  If you are on 8.x then some troubleshooting with netstat -rn on vfiler0 and the vfiler.

Re: vfiler setup issue

Yes I m on 8.0.2 P3 only. So what should I change in netstat –rn to make filer talk with JD domain (172.31) and vfiler talk to Nor domain..is it default route..if so can you help me what needs to be changed exactly.

Thanks,

Karthik

Re: vfiler setup issue

Make sure your vfiler0 interface is up and has a route

Sent from my iPhone 4S

Re: vfiler setup issue

The vfiler0 is up and running I hope as per below, when I give vif status, it shows me that e0a is up but e0a is down. Does this have anything to do with it.

Also, do we need to add the route in netstat –rn for vfiler fdvnor to nor domain gateway also.

fdlr1> netstat -rn

Routing tables

Internet:

Destination Gateway Flags Refs Use Interface

default 172.31.180.1 UGS 4610 526433 vif1

Thanks,

Karthik

Re: vfiler setup issue

Not sure what the issue is if up and down. Switch side? Your default route is there do that looks ok. Can the switch handle a tagged and utagged interface or is it configured on handle it?

Sent from my iPhone 4S

Re: vfiler setup issue

I think the interface is up, and has a default route. The switch supports vlan tagging in our envi. Also, there is a native vlan 300 on the switch itseems which supports fldrn filer. So they are asking do we need to configure this vlan 300 on filer ??

Thanks,

Karthik

Re: vfiler setup issue

Depends. It worked before you added the vlan. Sounds suspicious that it stops working untagged when you add a tagged vlan.

Sent from my iPhone 4S

Re: vfiler setup issue

This is the port configurations on our switch right now:

interface GigabitEthernet2/13

description FDLRNAS01_PortGroup#1.1

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 300

switchport trunk allowed vlan 300,339,340,413

switchport mode trunk

no ip address

speed 1000

duplex full

no cdp enable

As you can see above that there is native vlan 300. Do we need to setup on the filer fdlrn??. Actually i tried doing it, but had a doubt since it dint work that way too.

vif1 originally has 172.31.190.21 (During this time the users were able to access cifs shares)..Took downtime, I created vif1-300 and then assigned 172.31.190.37 (some address in the vlan 300 subnet) to vif1 and 172.31.190.21 (which is actual filer ip for communication) to vif1-300 and it did not allowed any communication to happen from the switch when pining or users were not able to see any cifs shares. Later, we backed off and put back to original where users were able to see cifs shares. Then I thought it dint worked since I dint added vif1-300 default route to gateway in the routing table So, creating vlan 300 on filer is right?? and would adding vif1-300 also in the routing table will able to allow users to see cifs shares??

fdlrn> netstat -rn

Routing tables

Internet:

Destination Gateway Flags Refs Use Interface

default 172.31.190.1 UGS 5710 523433 vif1

Thanks,

Karthik

Re: vfiler setup issue

can you paste the /etc/rc file info