Subscribe

vif has nfo enabled, can't add new vlan

Hi,

One of our customers has enabled network failover on 2nd level vifs for their cluster,

When trying to add a new vlan, they are getting error below

nbg2-fas13> vlan add fas13-2ndLvl01 316

vlan: Create failed. Negotiated failover is enabled on interface fas13-2ndLvl01.

nbg2-fas13> ifconfig -a

e0a: flags=0x8af0c867<BROADCAST,RUNNING,MULTICAST,TCPCKSUM,VLAN> mtu 1500

        ether 02:1b:21:a8:22:e0 (auto-1000t-fd-up) flowcontrol full

        trunked cra03-1stLvl01

e0b: flags=0x8af0c867<BROADCAST,RUNNING,MULTICAST,TCPCKSUM,VLAN> mtu 1500

        ether 02:1b:21:a8:22:e0 (auto-1000t-fd-up) flowcontrol full

        trunked cra03-1stLvl01

e1a: flags=0x8af0c867<BROADCAST,RUNNING,MULTICAST,TCPCKSUM,VLAN> mtu 1500

        ether 02:1b:21:a8:22:e0 (auto-1000t-fd-up) flowcontrol full

        trunked cra04-1stLvl02

e1b: flags=0x8af0c867<BROADCAST,RUNNING,MULTICAST,TCPCKSUM,VLAN> mtu 1500

        ether 02:1b:21:a8:22:e0 (auto-1000t-fd-up) flowcontrol full

        trunked cra04-1stLvl02

e1c: flags=0x274c867<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

        inet 192.168.1.13 netmask 0xffffff00 broadcast 192.168.1.255

        ether 00:1b:21:a8:22:e2 (auto-unknown-down) flowcontrol full

e1d: flags=0x270c866<BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

        ether 00:1b:21:a8:22:e3 (auto-unknown-down) flowcontrol full

c0a: flags=0x1f4c867<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 9000 PRIVATE

        inet 192.168.1.183 netmask 0xffffff00 broadcast 192.168.1.255

        ether 00:a0:98:17:6c:ba (auto-10g_twinax-fd-up) flowcontrol full

c0b: flags=0x1f4c867<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 9000 PRIVATE

        inet 192.168.2.79 netmask 0xffffff00 broadcast 192.168.2.255

        ether 00:a0:98:17:6c:bb (auto-10g_twinax-fd-up) flowcontrol full

e0M: flags=0x2b4c867<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

        inet 192.168.192.209 netmask 0xffffff00 broadcast 192.168.192.255

        partner e0M (not in use)

        ether 00:a0:98:17:6c:bc (auto-100tx-fd-up) flowcontrol full

e0P: flags=0x2b4c867<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500 PRIVATE

        inet 192.168.0.207 netmask 0xfffffc00 broadcast 192.168.3.255 noddns

        ether 00:a0:98:17:6c:bd (auto-100tx-fd-up) flowcontrol full

lo: flags=0x1b48049<UP,LOOPBACK,RUNNING,MULTICAST,TCPCKSUM> mtu 8160

        inet 127.0.0.1 netmask 0xff000000 broadcast 127.0.0.1

        ether 00:00:00:00:00:00 (RNIC Provider)

losk: flags=0x40a400c9<UP,LOOPBACK,RUNNING> mtu 9188

        inet 127.0.20.1 netmask 0xff000000 broadcast 127.0.20.1

cra03-1stLvl01: flags=0xaaf0c863<BROADCAST,RUNNING,MULTICAST,TCPCKSUM,VLAN> mtu 1500

        ether 02:1b:21:a8:22:e0 (Enabled interface groups)

        trunked fas13-2ndLvl01

cra04-1stLvl02: flags=0xaaf0c863<BROADCAST,RUNNING,MULTICAST,TCPCKSUM,VLAN> mtu 1500

        ether 02:1b:21:a8:22:e0 (Enabled interface groups)

        trunked fas13-2ndLvl01

fas13-2ndLvl01: flags=0xa2f0c863<BROADCAST,RUNNING,MULTICAST,TCPCKSUM,VLAN> mtu 1500

        partner fas14-2ndLvl01 (not in use)

        ether 02:1b:21:a8:22:e0 (Enabled interface groups)

        nfo enabled

fas13-2ndLv-301: flags=0x6b4c863<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM,NOWINS> mtu 1500

        inet 192.168.193.53 netmask 0xffffffc0 broadcast 192.168.193.63

        partner inet 192.168.193.54 (not in use)

        ether 02:1b:21:a8:22:e0 (Enabled interface groups)

fas13-2ndLv-631: flags=0x6b4c863<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM,NOWINS> mtu 1500

        inet 192.168.203.71 netmask 0xffffffc0 broadcast 192.168.203.127

        partner inet 192.168.203.72 (not in use)

        ether 02:1b:21:a8:22:e0 (Enabled interface groups)

fas13-2ndLv-601: flags=0x6b4c863<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM,NOWINS> mtu 1500

        inet 192.168.200.135 netmask 0xffffff80 broadcast 192.168.200.255

        partner inet 192.168.200.136 (not in use)

        ether 02:1b:21:a8:22:e0 (Enabled interface groups)

fas13-2ndLv-641: flags=0x6b4c863<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM,NOWINS> mtu 1500

        inet 192.168.204.135 netmask 0xffffff80 broadcast 192.168.204.255

        partner inet 192.168.204.136 (not in use)

        ether 02:1b:21:a8:22:e0 (Enabled interface groups)

fas13-2ndLv-650: flags=0x6b4c863<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM,NOWINS> mtu 1500

        inet 192.168.205.3 netmask 0xffffffe0 broadcast 192.168.205.31

        partner inet 192.168.205.4 (not in use)

        ether 02:1b:21:a8:22:e0 (Enabled interface groups)

nbg2-fas13>

nbg2-fas13> rdfile /etc/rc

#Regenerated by registry Mon Nov 14 12:21:20 UTC 2011

#Auto-generated by setup Tue Sep 20 10:54:08 UTC 2011

hostname nbg2-fas13

ifgrp create multi cra03-1stLvl01 -b ip e0a e0b

ifgrp create multi cra04-1stLvl02 -b ip e1a e1b

ifgrp create single fas13-2ndLvl01 cra04-1stLvl02 cra03-1stLvl01

ifconfig fas13-2ndLv-301 192.168.193.53 netmask 255.255.255.192 mtusize 1500 -wins partner 192.168.193.54

ifconfig fas13-2ndLv-631 192.168.203.71 netmask 255.255.255.192 mtusize 1500 -wins partner 192.168.203.72

ifconfig fas13-2ndLv-601 192.168.200.135 netmask 255.255.255.128 mtusize 1500 -wins partner 192.168.200.136

ifconfig fas13-2ndLv-641 192.168.204.135 netmask 255.255.255.128 mtusize 1500 -wins partner 192.168.204.136

ifconfig fas13-2ndLv-650 192.168.205.3 netmask 255.255.255.224 mtusize 1500 -wins partner 192.168.205.4

ifconfig fas13-2ndLvl01 mediatype auto partner fas14-2ndLvl01

ifconfig e0M `hostname`-e0M flowcontrol full partner e0M

ifconfig e1c `hostname`-e1c mediatype auto flowcontrol full

ifconfig fas13-2ndLvl01 nfo

route add default 192.168.193.1 1

route add net 192.168.225/27 192.168.205.1 1

routed on

options dns.domainname lan.gasp2.newbay.com

options dns.enable on

options nis.enable off

savecore

Do you think we could disable nfo, add new vlan, and then re-enable nfo ?

nbg2-fas13> ifconfig fas13-2ndLvl01 -nfo

nbg2-fas13> vlan add fas13-2ndLvl01 316

nbg2-fas13> ifconfig fas13-2ndLvl01 nfo

Thanks and regards

Jack

Re: vif has nfo enabled, can't add new vlan

That should work..you could also set nfo on each vlan ifconfig itself instead.

Re: vif has nfo enabled, can't add new vlan

Thanks Scott,

We shall give that a go alright so

We would need to get an outage to test new /etc/rc config if we went to enable on each vlan config

and this particular customer won't allow changes to /etc/rc with change request and tests after changes made

regards

Jack

Re: vif has nfo enabled, can't add new vlan

Makes sense. I prefer customers that plan and schedule Smiley Happy

Re: vif has nfo enabled, can't add new vlan

Cheers Scott,

it's the way we educate them

Re: vif has nfo enabled, can't add new vlan

Hi All,

I did some testing today, and unfortunately  it did not go too well, I was able to disable negotiated failover on my vif,

And then create the new vlans, but not re-enable it !

WENETAPP2> vlan create vif1 20

vlan: Create failed. Negotiated failover is enabled on interface vif1.

WENETAPP2> ifconfig vif1 -nfo

WENETAPP2> Wed Nov 30 15:53:12 GMT [WENETAPP2: nbt.nbns.registrationComplete:info]: NBT: All CIFS name registrations have completed for the local server.

WENETAPP2> vlan create vif1 20

vlan: vif1-20 has been created

WENETAPP2> ifconfig vif1-20 192.168.1.33

WENETAPP2> ifconfig -a

e0M: flags=0x2108866<BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

        ether 00:a0:98:29:45:4a (auto-unknown-cfg_down) flowcontrol full

e0a: flags=0x8ad08867<BROADCAST,RUNNING,MULTICAST,TCPCKSUM,VLAN> mtu 1500

        ether 02:a0:98:29:45:4a (auto-1000t-fd-up) flowcontrol full

        trunked vif1

e0b: flags=0x8ad08867<BROADCAST,RUNNING,MULTICAST,TCPCKSUM,VLAN> mtu 1500

        ether 02:a0:98:29:45:4a (auto-1000t-fd-up) flowcontrol full

        trunked vif1

lo: flags=0x1948049<UP,LOOPBACK,RUNNING,MULTICAST,TCPCKSUM> mtu 8160

        inet 127.0.0.1 netmask-or-prefix 0xff000000 broadcast 127.0.0.1

        ether 00:00:00:00:00:00 (VIA Provider)

vif1: flags=0xa2d08863<BROADCAST,RUNNING,MULTICAST,TCPCKSUM,VLAN> mtu 1500

        ether 02:a0:98:29:45:4a (Enabled virtual interface)

vif1-20: flags=0x2948863<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

        inet 192.168.1.33 netmask-or-prefix 0xffffff00 broadcast 192.168.1.255

        ether 02:a0:98:29:45:4a (Enabled virtual interface)

WENETAPP2> vlan add vif1 30

vlan: vif1-30 has been created

WENETAPP2>

WENETAPP2> ifconfig vif1-30 192.168.1.47

WENETAPP2> ifconfig -a

e0M: flags=0x2108866<BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

        ether 00:a0:98:29:45:4a (auto-unknown-cfg_down) flowcontrol full

e0a: flags=0x8ad08867<BROADCAST,RUNNING,MULTICAST,TCPCKSUM,VLAN> mtu 1500

        ether 02:a0:98:29:45:4a (auto-1000t-fd-up) flowcontrol full

        trunked vif1

e0b: flags=0x8ad08867<BROADCAST,RUNNING,MULTICAST,TCPCKSUM,VLAN> mtu 1500

        ether 02:a0:98:29:45:4a (auto-1000t-fd-up) flowcontrol full

        trunked vif1

lo: flags=0x1948049<UP,LOOPBACK,RUNNING,MULTICAST,TCPCKSUM> mtu 8160

        inet 127.0.0.1 netmask-or-prefix 0xff000000 broadcast 127.0.0.1

        ether 00:00:00:00:00:00 (VIA Provider)

vif1: flags=0xa2d08863<BROADCAST,RUNNING,MULTICAST,TCPCKSUM,VLAN> mtu 1500

        ether 02:a0:98:29:45:4a (Enabled virtual interface)

vif1-20: flags=0x2948863<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

        inet 192.168.1.33 netmask-or-prefix 0xffffff00 broadcast 192.168.1.255

        ether 02:a0:98:29:45:4a (Enabled virtual interface)

vif1-30: flags=0x2948863<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

        inet 192.168.1.47 netmask-or-prefix 0xffffff00 broadcast 192.168.1.255

        ether 02:a0:98:29:45:4a (Enabled virtual interface)

WENETAPP2> ifconfig vif1 nfo

ifconfig: invalid option 'nfo' on a physical VLAN interface

usage: "ifconfig ?" will list the accepted subcommands and arguments

WENETAPP2>

Any ideas ?

thanks and regards

Jack

Re: vif has nfo enabled, can't add new vlan

So with vlans it looks like nfo is per vlan ifconfig only. Unless ontap 8 and there is an ip on the base I tagged vif.

Re: vif has nfo enabled, can't add new vlan

Cheers Scott,

Only saw this now, yeas, it looks like that alright,

I shall investigate further next oppertunity i get

thanks & regards

Jack

Re: vif has nfo enabled, can't add new vlan

Each time, I have to ad VLAN on nfo interface, I do that.

I'm working on DoT 8.1 GA and NFO is set on the vif not per VLAN.

Re: vif has nfo enabled, can't add new vlan

Nfo can be applied to any interface you ifconfig. If the base Ifgrp then it won't apply to a vlan on that Ifgrp unless the vlan ifconfig has nfo. The base ifgrp is a different logical interface than the vlan. Apply nfo to any/every interface you want failover to occur on. Then make sure the options is set to any_nic or all_nics if you want all interfaces with nfo to have to fail or just one for the failover to occur.