Estimate Storage Efficiency Space Savings Using Space Savings Estimation Tool v4.1 (SSET 4.1).

by smoulton Former NetApp Employee on ‎2012-08-28 10:46 AM - edited on ‎2017-01-25 09:57 AM by Frequent Contributor

Estimate Storage Efficiency Space Savings Using Space Savings Estimation Tool version 4.1 (SSET 4.1).

 

Introduction:

SSET (Space Savings Estimation Tool) 4.1 simulates the algorithms used by NetApp deduplication, data compression, zero-block elimination and data compaction to give an estimate on space savings of an existing data set. The data set may reside on any storage that is accessible via a CIFS or NFS mount point, or inside a local directory on the client system.

  

This tool is a confidential NetApp® product. It is intended only for use by NetApp employees, authorized NetApp partners, and NetApp customers. 

 

Note: The tool is intended to be used for estimation purposes only

 

Features in SSET 4.1

Support for analysis of the following configurations:

  • Deduplication only savings estimate
  • Compression only savings estimate
  • Data Compaction only savings estimate
  • Combination of Deduplication, Compression and/or Data Compaction savings estimate

*Zero-block elimination savings estimate will be included in all the above configurations.

 

What's new in v4.1? 

- 2TB scan limit removed. The tool can process up to 1024PB of data in a single run.

- Performance improvements to make the tool run faster!

 

OS Support: Windows and Linux

 

Tool Support: The SSET 4.1 is only supported via NetApp Communities. Create a new discussion or comment on this page or

send mail to ng-wafl-pm for any questions or support.

 

Download Link:

NetApp customers, authorized NetApp partners and NetApp employees can download the tool from ToolChest

- NetApp employees and authorized NetApp partners can also download the tool from  Field Portal

 

 

Comments

All,

 

I am trying to download the SSET tool but I can't seem to find it on this page. It is supposed to be in the document somewhere. Can you tell me where it is?

 I am too looking for a download link. 

Link?

Yeah I just tried that link anf got this error: Error While Logging into the Field Portal You have experienced an error in the NetApp Single Sign-in login process. Would it not be better to just put this on the NOW site in the tools section?

Thanks 

allison Former NetApp Employee

@michaeljay Unfortunately, if it is in the Field Portal, it's meant for NetApp Partner use and not general customer use. If you need to use this tool, please contact your account manager or selling partner.

Anybody else gets "Percentage of Duplicate Data: 100.00"  for A-SIS deduplication (-a)?

I get that regardless of data I use it on.

New Contributor

Hi,

On what Linux version should this work???

 

xxx@toaster4:~/sset$ ls -l

total 708

-rwxr-xr-x 1 xxx yyy 434877 Jun 25 2015 find_space -rwxr-xr-x 1 xxx yyy 284700 Jun 25 2015 SSET 3.1 Communities Readme.pdf

 

xxx@toaster4:~/sset$ ./find_space

-bash: ./find_space: No such file or directory

 

xxx@toaster4:~/sset$ uname -a

Linux toaster4.mydomain.tv 3.2.0-4-amd64 #1 SMP Debian 3.2.73-2+deb7u2

x86_64 GNU/Linux

 

xxx@toaster4:~/sset$ ldd find_space

                not a dynamic executable

 

xxx@toaster4:~/sset$ file find_space

find_space: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.2.5, not stripped

 

 

Please advice!?

 

-Arnout

 

Looks like I potentially found the answer here. Will keep you posted.

http://ubuntuforums.org/showthread.php?t=1607086

where is the download link?

Member

"Download the attached SSET31_Win_Linux.zip file"

 

Where is the download link for the attached file?

Occasional Contributor

I'm getting the error that Arnout got. How do you run this on 64 bit Linux when you can't install the 32 bit libraries? It's RH 6 and I can't modify the build I have. 

Occasional Contributor

Answering my own question. You can get it to run by doing the following:

# mkdir /usr/software

# ln -s /lib64 /usr/software/lib

Member

Hi Team,

 

IHAC who is running the SSET tool in his environment for MongoDB on Cent OS ( Vmware ESXi), the error message is as :

 

 

 

bash: ./find_space: /usr/software/lib/ld-linux-x86-64.so.2: bad ELF interpreter: No such file or directory

 

 

Kindly assist in resolution.

 

 

 

Rgds,

Gurdeep Singh.

Member

IHAC that is running into issues. Here is the feedback he is giving us. Need to get him a response quickly.

 

most recent reply: 

I’m scanning a folder within the volume where the SSET tool resides, it is 1.6TB in size however there is plenty of free space, over 256GB worth. I have tried running the tool from the main C: drive and have attempted different combinations of the switches. I just noticed the output of the command showed the following - Usage Error: Could not recognize: ?p

This occurs no matter where I run the tool from? Thoughts 

 

Previous question from customer:

 

We were attempting to run the tool to receive stats for Deduplication, compression and compaction combined savings by issuing the following command :  e:\tools\find_space -f work.fp –p e:\DATA

The tool would prompt us for the user agreement and when answering yes its next step just displayed the usage arguments. Below is the output from the tool :

 

C:\Users\admin>e:\Tools\find_space -f work.fp -p e:\DATA

 

Data ONTAP Space Savings Estimation Tool Version 4.1

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

This tool is a confidential NetApp product. By running it you

agree to keep it and the results confidential between you and

NetApp. Do you accept the agreement and want to continue (Y/N) [N]? y

find_space: Usage Error: Could not recognize: ?p

==========================================================

 

Program: find_space

 

Description: This program scans the entire path (as provided with -p

             option) and estimates the  space savings that  will be

             achieved by Compression (switch -c), A-SIS deduplication

             (switch -a), Data compaction (switch -o) or Compression

             followed by A-SIS deduplication (switches -c and -a).

 

Usage: find_space  -a | -c | -o | -ac

                   [-h Help]

                   -f <name of log file>

                   [-g <Compression group size>]

                   [-o Do additional data compaction]

                   -p <path to scan>

                   [-T <temp dir>]

                   [-s <summary file>]

                   [-t <num of reader threads>]

                   [-w <num of worker threads>]

                   [-q quiet mode]

 

==========================================================

 

C:\Users\admin

 

 

Frequent Contributor

You need to specify the Deduplicaiton (-a), Compression (-c) and Compaction (-o) switch while running the command.

C:\Users\admin>e:\Tools\find_space –a –o –c –g 2 -f work.fp -p e:\DATA

The command options and example output are mentioned in the accompanying readme file.

 

New Contributor

Hello all!

I have an issue where a customer of mine is trying to run SSET against an NFS mounts ESX datastore from a linux machine. They are getting a "Could not allocate inode hash" message and then SSET quits.

Any advice on this?

Thanks!

 

From Customer:

[Host\user@machine:/vmfs/volumes] /tmp/find_space  -a -f /tmp/NetAppLogs/App_dedup.log -p J: -T /vmfs/volumes/qa_datastore0\ \(Fast\ Disk\)/NetAppTmp -s /tmp/NetAppLogs/App_dedupsummary.txt

Data ONTAP Space Savings Estimation Tool Version 4.1

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

This tool is a confidential NetApp product. By running it you

agree to keep it and the results confidential between you and

NetApp.

Do you accept the agreement and want to continue (Y/N) [N]? y

Could not allocate inode hash.

 

 

Warning!

This NetApp Community is public and open website that is indexed by search engines such as Google. Participation in the NetApp Community is voluntary. All content posted on the NetApp Community is publicly viewable and available. This includes the rich text editor which is not encrypted for https.

In accordance to our Code of Conduct and Community Terms of Use DO NOT post or attach the following:

  • Software files (compressed or uncompressed)
  • Files that require an End User License Agreement (EULA)
  • Confidential information
  • Personal data you do not want publicly available
  • Another’s personally identifiable information
  • Copyrighted materials without the permission of the copyright owner

Files and content that do not abide by the Community Terms of Use or Code of Conduct will be removed. Continued non-compliance may result in NetApp Community account restrictions or termination.