Subscribe

2,740,240 files in 742 folders - ack!

Greetings,

Can someone help me understand how the max inodes per volume limitation will affect me?

My filer is a V3240 HA pair, running DOT 8.0.2RC1 7-mode.

I have a voice call recording application which stores data as MP3s.  The current repository lives on direct-attached storage.  We want to move it to our filer.

There are currently 2,740,240 files in 742 folders.  Disk space consumed is 576GB.

Projected growth is 25% per year.  However for the first increment I've been asked to make 1TB of space available.

I've created a 1TB volume with 5% snap reserve and 0% fractional reserve with the intention of publishing it from the filer as a CIFS share.

But ... I can't set maximum files above 249,036.  Obviously this is a tad shy of both my current and anticipated needs. 

Any way around this?

One think I was wondering about ---- could I mount it as a FCP LUN instead of a CIFS share?

Thank you!

Re: 2,740,240 files in 742 folders - ack!

How exactly do you set it? Could you copy'n'paste command and output?

The smallest possible file on NetApp is 4K, so you should be able to set number of files to number of 4K blocks which is around 268,435,456 for 1TB volume. I have customers with more than 50M files in a volume.

You can't access volume via FCP/iSCSI. If you have license, you can create LUN though.

2,740,240 files in 742 folders - ack!

You can use the maxfiles command to query the current maximum files settings and to modify it. E.g. "maxfiles <volume> <maximum number of files>". But the default maxfiles of a 1 TB volume should already be more than enough to store less than 3 million files.

But perhaps you are hitting the maxdirsize instead of the maxfiles limit. If you do this will logged to the the message file of your controller.