Subscribe

Disabling multistore, with no vfilers?

We have an HA pair we just upgraded to 8.1.4, multistore is enabled  but I don't see any vfilers besides vfiler0. I'd like to turn multistore off, if only to stop these syslog entries that are filling up our logs:

Mon May  5 15:41:01 PDT [acp-vfiler@filer1b:kern.cli.cmd:debug]: Command line input: the command is 'vfiler run acp-vfiler'. The full command line is 'vfiler run acp-vfiler arp -s 192.168.3.239 0:50:cc:65:3b:ef'. ^M
Mon May  5 15:41:10 PDT [acp-vfiler@filer1b:kern.cli.cmd:debug]: Command line input: the command is 'vfiler run acp-vfiler'. The full command line is 'vfiler run acp-vfiler arp -s 192.168.3.225 0:50:cc:65:13:e0'. ^M
Mon May  5 15:41:11 PDT [acp-vfiler@filer1b:kern.cli.cmd:debug]: Command line input: the command is 'vfiler run acp-vfiler'. The full command line is 'vfiler run acp-vfiler arp -s 192.168.0.147 0:50:cc:64:44:93'. ^M
.... [every few seconds]

Has anyone disabled multistore to stop these messages? Will disabling multistore disrupt vfiler0?

Our ACP cabling has some minor issues, although all shelves can be reached with at least one path:

> storage show acp -a      

Alternate Control Path:  Enabled
Ethernet Interface:      e0P
ACP Status:              Active
ACP IP Address:          192.168.0.43
ACP Subnet:              192.168.0.1
ACP Netmask:             255.255.252.0
ACP Connectivity Status: Partial Connectivity

Shelf Module      Reset Cnt    IP Address      FW Version   Module Type  Status
----------------- ------------ --------------- ------------ ------------ -------
3c.00.A           000          192.168.0.205   01.41        IOM3         active
3c.00.B           NA           NA              NA           NA           NA
3c.01.A           000          192.168.3.225   01.41        IOM3         active
3c.01.B           NA           NA              NA           NA           NA
3c.02.A           000          192.168.0.239   01.41        IOM3         active
3c.02.B           NA           NA              NA           NA           NA
3c.03.A           000          192.168.0.87    01.41        IOM3         active
3c.03.B           000          192.168.0.147   01.41        IOM3         active
3c.04.A           000          192.168.3.135   01.41        IOM3         active
3c.04.B           000          192.168.3.187   01.41        IOM3         active
3c.05.A           000          192.168.0.211   01.41        IOM3         active
3c.05.B           000          192.168.0.209   01.41        IOM3         active
3d.10.A           000          192.168.3.240   01.41        IOM3         active
3d.10.B           000          192.168.3.239   01.41        IOM3         active
3d.11.A           000          192.168.3.133   01.41        IOM3         active
3d.11.B           000          192.168.3.89    01.41        IOM3         active

I think this is what any filer normally looks like with multistore enabled and no vfilers in use (vfiler0 is the "root/dom0/etc" vfiler):

> vfiler status -a
vfiler0                          running
   ipspace: default-ipspace
   IP address: 10.102.15.9 [MultiTrunk1]
   IP address: 10.102.16.9 [e0M]
   Path: / [/etc]
   UUID: 00000000-0000-0000-0000-000000000000
   Protocols allowed: 7
   Allowed: proto=rsh
   Allowed: proto=ssh
   Allowed: proto=nfs
   Allowed: proto=cifs
   Allowed: proto=iscsi
   Allowed: proto=ftp
   Allowed: proto=http
   Protocols disallowed: 0

Disabling multistore, with no vfilers?

Hi Wiley,

In if you have FAS 3040, 3070, 31xx, 60xx then you need to remove the license of multistore using command:

license delete multistore

For all other filers please disable below option:

licensed_feature.multistore.enable off

Hope this will address your issue.

Thanks,

Amit