Subscribe

FAS2040 No disks attached to the system

Hello,

 

We had a maintenance on the site, the netapp was moved to a new rack. After powered down the appliance and reconnect it to its new place, the ONTAP os is not loading, the system is not recognizing the disks even though when all the cabeling was checked.

 

AMI BIOS8 Modular BIOS
Copyright (C) 1985-2009,  American Megatrends, Inc. All Rights Reserved
Portions Copyright (C) 2009 NetApp, Inc. All Rights Reserved
BIOS Version 6.1
+++++++++++++++++++++++++++++++++++

Boot Loader version 2.1
Copyright (C) 2000-2003 Broadcom Corporation.
Portions Copyright (C) 2002-2008 NetApp

4096MB RAM installed
Could not set environment variable 'BMC_FIRMWARE_URL': Environment variable is read-only
CPU Type: Intel(R) Xeon(R) CPU                  @ 1.66GHz


Starting AUTOBOOT press Ctrl-C to abort...
Loading X86/freebsd/image1/kernel:..0x200000/8113940 0x9bcf14/724580 0xa6e000/593920 Entry at 0x00248810
Loading X86/freebsd/image1/platform.ko:0xaff000/386720 0xb5e6a0/28064 0xb65440/120496
Starting program at 0x00248810
NetApp Data ONTAP 8.1.4P8 7-Mode

Copyright (C) 1992-2014 NetApp.
All rights reserved.
md1.uzip: 25536 x 16384 blocks
md2.uzip: 5760 x 16384 blocks
*******************************
*                             *
* Press Ctrl-C for Boot Menu. *
*                             *
*******************************
Jul 10 19:24:04 [localhost:cf.nm.nicTransitionUp:info]: HA interconnect: Link up on NIC 0.
Jul 10 19:24:05 [localhost:rv.connection.established:info]: cfo_rv is connected on NIC 0
Jul 10 19:24:11 [localhost:fci.initialization.failed:error]: Initialization failed on Fibre Channel adapter 0a.
Jul 10 19:24:11 [localhost:fci.initialization.failed:error]: Initialization failed on Fibre Channel adapter 0b.
Jul 10 19:24:14 [localhost:sas.initialization.failed:error]: Initialization failed on SAS adapter 0d.
Jul 10 19:24:17 [localhost:netif.linkUp:info]: Ethernet e0P: Link up.
Jul 10 19:24:19 [localhost:sas.cable.pushed:debug]: Cable attached to SAS port "0d" was pushed in.
Jul 10 19:24:20 [localhost:netif.linkUp:info]: Ethernet e0b: Link up.
Jul 10 19:24:20 [localhost:netif.linkUp:info]: Ethernet e0a: Link up.
Jul 10 19:24:21 [localhost:netif.linkDown:info]: Ethernet e0c: Link down, check cable.
Jul 10 19:24:21 [localhost:netif.linkDown:info]: Ethernet e0d: Link down, check cable.
Jul 10 19:24:30 [localhost:diskown.isEnabled:info]: software ownership has been enabled for this system
Jul 10 19:24:30 [localhost:config.noPartnerDisks:CRITICAL]: No disks were detected for the partner; tWAFLhis node will be C unable to takeoPLver correctly
Jul 10 19:24:30R  [localhost:callis enhome.dsk.config:ablwarning]: Call hedome for DISK CON. CFIGURATION ERRORhe
Jul 10 19:24ckl:30 [localhost:discs.framework.enat =bled:info]: The  0DCS framework isx7f enabled on thisf8 node.
st 127.0.10.1: g
ateway 127.0.20.1
Jul 10 19:24:30 [localhost:sas.link.error:error]: Could not recover link on SAS adapter 0d after 15 seconds. Offlining the adapter.
Jul 10 19:24:31 [localhost:wafl.memory.status:inWAfo]: 1994MB of mRNemory is currentINly available forG: the WAFL file s 0ystem.
Jul 10  d19:24:31 [localhisost:cf.nm.nicTraksnsitionDown:warn fing]: HA intercoounnect: Link downnd on NIC 0.
 10 19:24:31 [lo
tStat.change:inf
                So]: no mailbox itonstance on localra side.
Jul 10 ge19:24:31 [localh Aost:fmmb.instStadat.change:info]: ptno mailbox instaernce on partner ss ide.
Could not find t1 [localhosunt:cf.fm.noMBDiskd:sOrIc:warning]:
                2he local mailbox F disks. Could noibt determine the refirmware state o Cf the partner thharough the HA intnnerconnect.
Julel 10 19:24:31 [lo Scalhost:rv.connetoction.torndown:iranfo]: cfo_rv is getorn down on NIC A 0
Jul 10 19:2da4:31 [localhost:ptcf.rv.notConnectered:error]: Connes ction for 'cfo_rfov' failed.
und!
2 SAS Adapters found!
0 Parallel SCSI Storage Adapters found!
0 ATA Adapters found!

Target Adapters found:
0 Fibre Channel Target Adapters found!
2 iSCSI Target Adapters found!
1 Unknown Target Adapters found!

Check that disks have been assigned ownership to this system (ID 142253630) using the 'disk show' and 'disk assign'
commands from maintenance mode.

WARNING: there do not appear to be any disks attached to the system.
No root volume found.
Rebooting... (press ctrl-c during boot to break reboot loop)
Uptime: 1m19s
System rebooting...
Mon Jul 10 19:24:34 GMT [bmc.asup.send:notice]: Sending ASUP: WARNING: REBOOT (abnormal).

AMI BIOS8 Modular BIOS
Copyright (C) 1985-2009,  American Megatrends, Inc. All Rights Reserved
Portions Copyright (C) 2009 NetApp, Inc. All Rights Reserved
BIOS Version 6.1
+++++++++++++++++++++++++++++++++++

Boot Loader version 2.1
Copyright (C) 2000-2003 Broadcom Corporation.
Portions Copyright (C) 2002-2008 NetApp

4096MB RAM installed
Could not set environment variable 'BMC_FIRMWARE_URL': Environment variable is read-only
CPU Type: Intel(R) Xeon(R) CPU                  @ 1.66GHz


Starting AUTOBOOT press Ctrl-C to abort...
Loading X86/freebsd/image1/kernel:..0x200000/8113940 0x9bcf14/724580 0xa6e000/593920 Entry at 0x00248810
Loading X86/freebsd/image1/platform.ko:0xaff000/386720 0xb5e6a0/28064 0xb65440/120496
Starting program at 0x00248810
NetApp Data ONTAP 8.1.4P8 7-Mode

 

When running Maintenance mode, I have these messages from the disk show command

 

disk show -a

Local system ID: 14253630

 

disk show: No disks match option -a

 

disk show -v

Local system ID: 14253630

 

disk show: No disks attached to the system

 

disk show -n

Local system ID: 14253630

 

disk show: No unassigned disks

 

Any ideas on what's going on?

 

D0F3C1A2.PNG

Re: FAS2040 No disks attached to the system

[ Edited ]

I'll recommend you open a case with netapp support.

 

if the system is unbale to find any disk, it should be a cabling error or shelf is not powered on.

 

do you mind running the following commands and attachch the output.

 

sysconfig -a
sasadmin expander_map

How many shelf is attached to it and the shelf model ?

 

Here is the FAS2040 System Installation and Setup guide

It have the cabling examples.. depends on various shelf model (FC/SAS)

 

https://library.netapp.com/ecm/ecm_download_file/ECMM1280295

 

Robin.

Re: FAS2040 No disks attached to the system

Thank you!

 

Here is the sysconfig -v (option -a is not available)

 

*> sysconfig -a
usage: sysconfig -v [ <slot> ]
*> sysconfig -v
        NetApp Release 8.1.4P8 7-Mode: Wed Feb  4 02:09:24 PST 2015
        System ID: 0142253630 (); partner ID: 0142253670 ()
        System Serial Number: 700000831015 ()
        System Rev: B2
        System Storage Configuration: Unknown
        System ACP Connectivity: Additional Connectivity
        slot 0: System Board 1665 MHz (110-00133 A8)
                Model Name:         FAS2040
                Part Number:        110-00133
                Revision:           A8
                Serial Number:      8035902
                BIOS version:       6.1
                Processors:         2
                Processor type:     Intel(R) Xeon(R) CPU                  @ 1.66GHz
                Memory Size:        4096 MB
                NVMEM Size:         512 MB of Main Memory Used
                CMOS RAM Status:    OK
                Controller:         A
        slot 0: Internal BGE 10/100 Ethernet Controller
                e0P MAC Address:    00:a0:98:4c:4f:44 (auto-100tx-fd-up)
                Device Type:        BCM5721
        slot 0: Dual 10/100/1000 Ethernet Controller G20
                e0a MAC Address:    00:a0:98:4c:4f:49 (auto-1000t-fd-up)
                e0b MAC Address:    00:a0:98:4c:4f:48 (auto-100tx-fd-up)
                e0c MAC Address:    00:a0:98:4c:4f:47 (auto-unknown-down)
                e0d MAC Address:    00:a0:98:4c:4f:46 (auto-unknown-down)
                Device Type:        Rev 6
        slot 0: ATA/IDE Adapter 0e (0x000001f0)
                0e.0             SMART CF   20090529  977MB  512B/sect (2011071206A5DC93DC93)
        slot 0: Interconnect HBA:   Mellanox IB MT25204
                GUID: 0x212800004c4f44  LID: 0x4        Remote LID: 0x0
                Firmware rev:           1.0.800
                Hardware rev:           160
                Command rev:            1
                Cluster Interconnect Port: port not active
        slot 0: FC Host Adapter 0a (QLogic 2432 rev. 2, L-port, <OFFLINE (hard)>)
                Firmware rev:      5.4.100
                Host Loop Id:      0
                FC Node Name:      5:00a:098001:5d9866
                FC Port Name:      5:00a:098001:5d9866
                SFP Vendor:        FINISAR CORP.
                SFP Part Number:   FTLF8524P2BNV
                SFP Serial Number: PJ93K12
                SFP Capabilities:  1, 2 or 4 Gbit
                Link Data Rate:    N/A
        slot 0: FC Host Adapter 0b (QLogic 2432 rev. 2, L-port, <OFFLINE (hard)>)
                Firmware rev:      5.4.100
                Host Loop Id:      0
                FC Node Name:      5:00a:098101:5d9866
                FC Port Name:      5:00a:098101:5d9866
                SFP Vendor:        FINISAR CORP.
                SFP Part Number:   FTLF8524P2BNV
                SFP Serial Number: PJ934YU
                SFP Capabilities:  1, 2 or 4 Gbit
                Link Data Rate:    N/A
        slot 0: SAS Host Adapter 0c (LSI Logic 1068E rev. B3, SAS, <UP>)
                Firmware rev:      1.31.02.00
                Base WWN:          5:00a098:0015d4e:38
                Phy State:         [0] Enabled, 3.0 Gb/s
                                   [1] Enabled, 3.0 Gb/s
                                   [2] Enabled, 3.0 Gb/s
                                   [3] Enabled, 3.0 Gb/s
                Shelf   0: ESAS  Firmware rev. SAS A: 05 SAS B: 05
        slot 0: SAS Host Adapter 0d (LSI Logic 1068E rev. B3, SAS, <OFFLINE (hard)>)
                Firmware rev:      1.31.02.00
                Base WWN:          5:00a098:0015d4e:3c
                Phy State:         [4] Enabled, Rate unknown
                                   [5] Enabled, Rate unknown
                                   [6] Enabled, Rate unknown
                                   [7] Enabled, Rate unknown
                QSFP Vendor:        Molex Inc.
                QSFP Part Number:   112-00177+A0
                QSFP Type:          Copper 2m ID:01
                QSFP Serial Number: 125320647

 

 

Here is the result of sasadmin expander_map

 

*> sasadmin expander_map

Expanders on channel 0c:
Level  1: WWN 500c0ff00dacfd3f, ID  0, Serial Number '          0DACFD', Product 'NA-1200-SL-SAS  ', Rev '0500', Slot A

Expanders on channel 0d:
Cannot Complete operation on channel 0d; Status Not Available.

 

 

I have a FAS 2040 and a DS4243, the cabeling is currently like this:

 

fas2040 ds4243.png

 

Should I be connecting to the IOIO port?

Re: FAS2040 No disks attached to the system

[ Edited ]

 

Your SAS & ACP Cabling seems to be correct.

 

Node-01 0d => Shelf 01 Module-A Square (assuming additional shelf ID is 01)

Node-02 0d => Shelf 01 Module-B Square

 

ACP should be connecting to e0P Port.. not the IOIOI port (that the serial console port)

Screen Shot 2017-07-10 at 5.11.05 PM.png

 

As long as your shelf is powered on and all 4 Power Supply is connected ( Yes some model 15K SAS Disk needs lot of power, so you should be connecting all 4 power to DS4243 shelf)

The only problem i can see is the cable is not insearted and fully seated or the cable is faulty.

 

Do you have the same problem from Node-2, are you unable to see the disks from node-2 as well?

 

robin.