Subscribe

FAS2040 unable to send commands via serial connection

We have an old FAS 2040 that we're trying to get setup for use in an upcoming field opp (USMC). We do not have the password that was used the last time the device was setup. I am trying to get into the boot menu and do a full wipe via the CTRL-C method but we can only recieve commands from the hyperterminal shell and cannot send anything. I've tried using other computers, I've tried reinstalling the USB to Serial addapter drivers, I've tried other cables and nothing has worked so far. Any help would be greatly appreciated to figure out how to send commands to the FAS2040.

Re: FAS2040 unable to send commands via serial connection

The correct serial communication settings for FAS2040 is as follows:

 

baud rate: 9600

Data Bits : 8

Stop bits : 1

Parity: None

Flow Control : None

 

Please note that most of the terminal emulation programs have Flow control set to Xon/Xoff by default. That's a common mistake. You could also try different emulations such as VT100/ANSI etc to find which one works.

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.
Cannot find the answer you need? No need to open a support case - just CHAT and we’ll handle it for you.

Re: FAS2040 unable to send commands via serial connection

All the serial communications settings are correct, including flow control. We're able to receive output from the FAS just cannot send commands. We've tried this on Putty & HyperTerminal and the issue persists on both. We've used different serial cables & usb-to-serial adapters. We even plugged it into a Cisco switch and we were able to send that commands. So it makes us think this is an issue with the FAS. Not sure what's causing us to not be able to send commands to the FAS. Any other suggestions?

Re: FAS2040 unable to send commands via serial connection

[ Edited ]

It seems like a hardware issue, unless you are seeing the same behaviour on both controller A and controller B.

Please open a case with NetApp support to see if the motherboard can be replaced.

 

If you see the same behaviour on both, then try enabling local echo on the hyperterminal program.

  1. On the HyperTerminal File menu, click Properties.
  2. On the Settings tab, click ASCII Setup.
  3. Check the Echo typed characters locally box.
If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.
Cannot find the answer you need? No need to open a support case - just CHAT and we’ll handle it for you.