Community

Subscribe
Highlighted

FAS3140 slow disk speed on Windows Host

hello all,

quick question please


i have a Windows 2012 R2 Server and i have connect a lun from a FAS3140 via FC 4GB/ports (MS native MPIO is configured and tested)


the lun from the FAS is from an aggregate that have SATA disks (about 20 TB) the lun is 15 GB (ALUA is enabled and default config applied on vol/lun on the storage side)


testing the speed on the windows server drive (15GB lun) with a common utiliy the "hd_speed" i get very low throughput not above 140 MB/s on a 64k block size on the disk provided from the FAS (15GB lun)


comparing these speed with a common desktop with a single SATA drive rising the speed around 120MB/s on the same block size i am a little confused/cautious if the lun speed provided from the FAS on the Windows Server is normal or not..?

I would expect better and faster speeds from an enterprise storage


any feedback/comments will be welcome


Regards

Re: FAS3140 slow disk speed on Windows Host

Could you elaborate on what type of IO you are generating when using the benchmarking tool? (Sequential/Random for example).

Dan

Re: FAS3140 slow disk speed on Windows Host

hi thanks for the response

using hdspeed utility i get sequential read 130 to 140 MBs at 64k block size

using Parkdale utility at 64k block size check the results above

equential read speed: 142 MB/s

Radom QD32 2,9MB/s - 754 IOPS - 1.33ms

my regards

Re: FAS3140 slow disk speed on Windows Host

Some tasks won't perform all that much better on SAN than DAS(even spinning disks).  I have no idea how else to describe/categorize what's what, but that's been my observation.  One of them being a certain database application(not the famous ones ).  But there are a couple of things to keep in mind:

1. Did you check the latency?  I'd collect a perfstat and have NetApp tell you if volume and LUN latency counters are reporting high numbers.  With your setup, at that number, both counters should be pretty low.  If that's the case, then the delay is somewhere beyond your storage.

2. Did you tweak thread count/parallelism?  I don't know about the tool you're using, but these stress test tools usually let you play with thread count/block size/data size/file count/random-ness/read% vs write%.

3.  At the risk of sounding like a NetApp apologist(I'm a customer), could some of this be on your tool?  A few of our HA pairs are like yours(32xx with SATA aggrs) and a Microsoft stress tool for Exchange 2010 POC pumped out 800+MB/s without the latency hitting 10ms and the bottleneck was that the links were 2x 4Gbps.  I think these numbers you and I get can depend on the tools and their settings. 

Re: FAS3140 slow disk speed on Windows Host

Hi XARIS_SMSM,

Just wondering if you found a solution to your slow disk speeds on Windows 2012 R2 with a Netapp FC LUN on 4GB FC ports ?

I have a very similar setup to yours and am getting even worse performance - max average of around 65MB/second writes, and my aggregate is 100 disk 15K SAS 600GB and a 16TB LUN size.

I have logged a case with support and have uploaded a perfstat, but they have not gotten back to me yet.

Thanks.