Subscribe
Accepted Solution

Quota (and quota report) not working

Hi,

I have a strange problem on my filer.
I created a Qtree "test" on a volume "VOLUME".
I also defined a "user quota" of 1GB/user and with a threshold of 800MB.
I checked the "/etc/quotas" file:

#Auto-generated by setup Fri Jun 29 17:36:20 GMT 2012

*       user@/vol/VOLUME/test     1048576K        -       819200K -       -


and everything seems OK.

But, the quota doesn't seem to apply. Moreover, the "quota report" command doesn't even show that the quota applies:

FAS2240> quota report /vol/VOLUME/test/JCL/File_1.exe

                                 K-Bytes             Files

Type       ID    Volume    Tree  Used      Limit     Used    Limit   Quota Specifier

----- -------- -------- -------- --------- --------- ------- ------- ---------------

quota: no quota for file /vol/VOLUME/test/JCL/File_1.exe.

Do I miss something ?

Thanks,

Regards,

Jeremy

Re: Quota (and quota report) not working

Did you remember to turn quotas on this volume ("quota on VOLUME")?

Re: Quota (and quota report) not working

Yes, quotas are already enabled on this volume.
They even seem to be effective on another qtree. FYI this another qtree is listed when I do a "quota report" command.

Re: Quota (and quota report) not working

You might want to turn off quotas on this volume and than turn them back on to force a "rebuild". running "quota status" will let you know when the quota rebuild has been completed.

Re: Quota (and quota report) not working

Well you are correct with the steps. However, if you haven't restarted the Quota services then the new change in the file will not come into effect.

Re: Quota (and quota report) not working

James.Littlefield was right.
Thanks for all.
Regards,

Jeremy