Subscribe

SNMPD Errors

I am reposting this here since there are more eyeballs.  I also posted this in the NOW community....

Recently, we upgraded all of our filers to current DOT version.  We were on 7.2.3 and we migrated to 7.3.1.  Ever since we migrated we get the following errors in the CLI...


Tue Sep  8 08:49:17 PDT [FILERHOSTNAME: snmpd:error]: send response:
Tue Sep  8 08:49:17 PDT [FILERHOSTNAME: snmpd:error]:     -- .1.3.6.1.2.1.1.2.0

We are clustering.  These are FAS3000 and FAS2000 series filers (3020's and 2020's).

I also notice I get SSL errors when attempting to use the web management (although we do most of our stuff CLI anyways).  The web management gives the following error when we open FilerView

An error occurred during a connection to 10.0.0.41:443.


You have received an invalid certificate.  Please contact the server administrator or email correspondent and give them the following information:


Your certificate contains the same serial number as another certificate issued by the certificate authority.  Please get a new certificate containing a unique serial number.


(Error code: sec_error_reused_issuer_and_serial)

Does anyone have any thoughts on this?  I am most concerned about the SNMPD:ERROR we are getting above.

Re: SNMPD Errors

I encounterd that SSL error today from within Firefox. I resolved it by generating a new SSL certificate:

secureadmin setup -f ssl

Re: SNMPD Errors

Thanks.  That fixed the SSL error in browser.

Still looking for guidance on the CLI errors I see regarding SNMPD...

I don't want to shut SNMPD off for obvious reasons, but to date that's the only way I have found to eliminate the CLI error.

Re: SNMPD Errors

It looks like your Gateway / Route is not configured properly. Please check if your gateway ip is correct and your able to reach other network properly.

This should solve your problem


~Daniel

Re: SNMPD Errors

If you accept the certificates permanently then you might have to clean it up from the browser cache. In this case you better re-run the SSL setup or don't save the certificate in permanent way until unless you are going to keep the SSL certificate common.

Thanks

Daniel

Re: SNMPD Errors

Hi Daniel

I have also had this problem several months now without finding any solutions.

What do you mean about gateway/routes?

I have this on 5 2020's and 1 dual controller 2050 that are placed in different parts of the world and all can communicate nicely with everything else, so there is no indication that the problem is related to gateway/routing.

Best regards

Jeremy

Re: SNMPD Errors

Hi

While searching for snmpd error message, I saw in this thread  couple of you had the same problem.  We recently getting this error message on the command line interface.  I am wondering did you find solution for the problem. If it is, please can you reply about how did you fix the problem. I really appreciate any feedback.

Sat Apr 23 09:04:55 EDT [netapp2050-2: snmpd:error]:     -- .1.3.6.1.2.1.2.2.1.16.3

Sat Apr 23 09:04:59 EDT [netapp2050-2: snmpd:error]: send response:

Sat Apr 23 09:09:55 EDT [netapp2050-2: snmpd:error]:     -- .1.3.6.1.2.1.2.2.1.16.3

Sat Apr 23 09:09:59 EDT [netapp2050-2: snmpd:error]:     -- .1.3.6.1.2.1.2.2.1.16.2

Thanks

Rani

Re: SNMPD Errors

Hi,

This is a known  bug.  You guys really need to learn how to use the bug tools on NOW.

http://now.netapp.com/NOW/cgi-bin/bol?Type=Detail&Display=344812

Re: SNMPD Errors

Update ONTAP.