Subscribe
Accepted Solution

Spare disks not displayed

Hi guys,

I'm trying to add more disks to my aggregate, but I'm not getting it because it seems that the storage is not recognizing the disks.

Here is my outputs:

robin> sysconfig -r

Aggregate aggr0 (online, raid_dp) (block checksums)

  Plex /aggr0/plex0 (online, normal, active)

    RAID group /aggr0/plex0/rg0 (normal)

      RAID Disk Device          HA  SHELF BAY CHAN Pool Type  RPM  Used (MB/blks)    Phys (MB/blks)

      --------- ------          ------------- ---- ---- ---- ----- --------------    --------------

      dparity   0c.00.7         0c    0   7   SA:A   -  SATA  7200 423111/866531584  423946/868242816

      parity    0c.00.3         0c    0   3   SA:A   -  SATA  7200 423111/866531584  423946/868242816

      data      0c.00.11        0c    0   11  SA:A   -  SATA  7200 423111/866531584  423946/868242816

Spare disks (empty)

robin> disk show -n

disk show: No disks match option -n.

Even any spares was not displayed, I have three more disks in positions  0c.00.2,  0c.00.6 and  0c.00.10.

My question is. What problem could let the disks not to be displayed? Maybe, firmware version?

Thanks in advance for any help.

Re: Spare disks not displayed

Hi,

>sysconfig -a
>disk show -v

What kind outputs you get from those commands?


Ismo.

Re: Spare disks not displayed

The disks were displayed with 'disk show -v'

robin> disk show -v

  DISK       OWNER                      POOL   SERIAL NUMBER         HOME 

------------ -------------              -----  -------------         ------------- 

0c.00.10     batman    (142219817)    Pool0  9QMC6BX4              batman    (142219817)

0c.00.11     robin     (142219724)    Pool0  9QMBC3V0              robin     (142219724)

0c.00.3      robin     (142219724)    Pool0  9QMBC3T0              robin     (142219724)

0c.00.6      batman    (142219817)    Pool0  9QMAJMVR              batman    (142219817)

0c.00.2      batman    (142219817)    Pool0  9QMBD8E3              batman    (142219817)

0c.00.7      robin     (142219724)    Pool0  9QMBDCNE              robin     (142219724)

How can I unassign these disk from controller 'batman' ? Thanks!

Re: Spare disks not displayed

I've tried 'disk remove_ownership' in advanced mode, but the system reply with these messages:

robin> priv set advanced

Warning: These advanced commands are potentially dangerous; use

         them only when directed to do so by NetApp

         personnel.

robin*> disk remove_ownership 0c.00.2 

disk remove_ownership: Disk 0c.00.2 is not owned by this node.

I'm running with just one controller. 'batman' is not present in the base enclosure of FAS2040. How can I remove ownership in this scenario? Thanks!

Re: Spare disks not displayed

hi,

yeah, you can't remove ownership, because it's owned by other node.
But in priv set advanced, you can assign that disk if you use -f flag.
>disk assign -f <disk>
or
>disk assign <disk> -f
Can't remeber which


Ismo.

Re: Spare disks not displayed

I got it by running:

robin> disk assign 0c.00.2 -s unowned -f

robin> disk assign 0c.00.6 -s unowned -f

robin> disk assign 0c.00.10 -s unowned -f

Thanks man!