Community

Subscribe
Highlighted

Sysconfig -d shows disk not available & sysconfig -a 0.0GB 0B/sect (Found in scan)

Hi,

I have Netapp FAS 2040, 24drive

I am facing the error that There is no enough spare disk in /aggr1/plex0/rg0.

There are two spare drives. But still its showing 0Spare now.

Disk show -a & -n in both those drives are unseen.

output of

>sysconfig -d

0d.01.2         0d    1   2     SA:A    Not available

0d.01.3         0d    1   3     SA:A    WD-WMATVxxxx

0d.01.4         0d    1   4     SA:A    WD-WMATVxxxx

0d.01.5         0d    1   5     SA:A    WD-WMATVxxxx

0d.01.6         0d    1   6     SA:A    Not available.

output of

>sysconfig -a

01.0 : NETAPP   X302_WMARS01TSSM NA04 847.5GB 512B/sect (WD-WMATVxxxx)

01.1 : NETAPP   X302_WMARS01TSSM NA04 847.5GB 512B/sect (WD-WMATVxxxx)

01.2 : NETAPP   X302_WMARS01TSSM NA04   0.0GB 0B/sect (Found in scan)

01.6 : NETAPP   X302_WMARS01TSSM NA04   0.0GB 0B/sect (Found in scan)

The device has physically  24 drives & 22 are blinking green, Those two drives are indicating steady Green Led.

Reply Please.

Thanks,

Ashish


Re: Sysconfig -d shows disk not available & sysconfig -a 0.0GB 0B/sect (Found in scan)

1. Update all you disk firmware, you can download it from support website in download section.

2. You should try reseat those drives, (if they are spares), if that does not work.

Open a case with NetApp support, those two drives would need replacement.

Thanks,
Sahil

Re: Sysconfig -d shows disk not available & sysconfig -a 0.0GB 0B/sect (Found in scan)

Hi,I have tried to reseat those drives still the same information in sysconfig

>Disk device 0d.01.2: Device returns not yet ready: CDB 0x25: Sense Data SCSI:not ready - Drive spinning up (0x2 - 0x4 0x1 0x0)(3).

>Disk device 0d.01.6: Device returns not yet ready: CDB 0x25: Sense Data SCSI:not ready - Drive spinning up (0x2 - 0x4 0x1 0x0)(2).

>device 0d.01.2: excessive victim abort: delta time 102102: retry CDB 0x25: victim retry count 100: retry count 4: timeout retry count 0: path retry count 4: adapter status 0x14: target status 0x0: sense data SCSI:no sense -  (0x0 - 0x0 0x0 ).

Tue Jun 10 14:48:14 IST [sfu.firmwareUpToDate:info]: Firmware is up-to-date on all disk shelves.

>sysconfig -v

01.0 : NETAPP   X302_WMARS01TSSM NA04 847.5GB (1953525168 512B/sect)

                01.1 : NETAPP   X302_WMARS01TSSM NA04 847.5GB (1953525168 512B/sect)

               01.2 : NETAPP   X302_WMARS01TSSM NA04   0.0GB (        0 0B/sect) (Found in scan)

                01.3 : NETAPP   X302_WMARS01TSSM NA04 847.5GB (1953525168 512B/sect)

                01.4 : NETAPP   X302_WMARS01TSSM NA04 847.5GB (1953525168 512B/sect)

                01.5 : NETAPP   X302_WMARS01TSSM NA04 847.5GB (1953525168 512B/sect)

                01.6 : NETAPP   X302_WMARS01TSSM NA04   0.0GB (        0 0B/sect) (Found in scan)

                01.7 : NETAPP   X302_WMARS01TSSM NA04 847.5GB (1953525168 512B/sect)

Any clue why so?

Re: Sysconfig -d shows disk not available & sysconfig -a 0.0GB 0B/sect (Found in scan)

Next step would be update your disk firmware and disk qualification package.

Re: Sysconfig -d shows disk not available & sysconfig -a 0.0GB 0B/sect (Found in scan)

the disk firmware and disk qualification package is already updated.

Re: Sysconfig -d shows disk not available & sysconfig -a 0.0GB 0B/sect (Found in scan)

This is a problem with block-size (512 vs.520), you can try to boot into maintenance mode and use the scsi format.

*>scsi format <device_name>

Re: Sysconfig -d shows disk not available & sysconfig -a 0.0GB 0B/sect (Found in scan)

You can't update disk firmware if Data ONTAP cannot access disks; but I agree, disk qualification should be kept up to date.

Re: Sysconfig -d shows disk not available & sysconfig -a 0.0GB 0B/sect (Found in scan)

the device is single controller.

& <the device_name> is for Netapp device or disk name ?

Is there something wrong with disk drives or with the DOT?

Re: Sysconfig -d shows disk not available & sysconfig -a 0.0GB 0B/sect (Found in scan)

the <device_name> is the disk name.

I do have this problem more times, maybe the disks if there are refurbished hardware where used in another system/vendor with other block size.

But such a disk drive never fail after the scsi format.

Re: Sysconfig -d shows disk not available & sysconfig -a 0.0GB 0B/sect (Found in scan)

is there a work around? lets say if controller is in production and we do not to open change ticket just to reboot system maintenance mode just to format disks correctly.