Subscribe

Unable to enable PCS on FAS3050

We just updated two systems (FAS3050C and FAS3040A) from 7.2.6.1 to 7.3.2. Running 7.2.6.1 I was able to activate PCS on both systems (as described in TR-3681). Now running 7.3.2 old ext_cache.* is gone and I have only flexscale.* namespace. I can activate PCS on FAS3040A without issues; but on FAS3050C I get

host:~ # rsh fas options flexscale
flexscale.enable             off        (same value in local+partner recommended)
flexscale.lopri_blocks       off        (same value in local+partner recommended)
flexscale.normal_data_blocks off        (same value in local+partner recommended)
flexscale.pcs_high_res       off        (same value in local+partner recommended)
flexscale.pcs_size           0GB        (same value in local+partner recommended)
host:~ # rsh fas options flexscale.enable on
FlexScale PCS is not active and cannot be enabled.
host:~ # rsh fas options flexscale.enable pcs
FlexScale PCS is not active and cannot be enabled.
host:~ # rsh fas options flexscale.pcs_size 16
FlexScale PCS is not active and cannot be configured.

Is it a known bug? Even if I cannot use PAM II on FAS3050, I still can use PAM I and that is what I'd like to measure.

Re: Unable to enable PCS on FAS3050

Hi

According to system configuration guide PAM I is not supported on FAS3050.

It is supported starting from ONTAP 7.3RC2 only.

I can't find TR you talked about and any documentation about ext_cache option.

Could you please explain what this option is for or give URL to docs.

Thank you

Nick.

Re: Unable to enable PCS on FAS3050

OK, you are right; PAM is PCIe and of course is not supported by 3050; I cnfused it with 3040 (where PAM II is not supported).

But the point is different. I needed PCS to check whether plattform change to allow PAM would make sense (i.e. how much saving PAM would be). It was possible under 7.2.6.1 and is not possible now. To me it is regression

You can find about PCS in http://ctistrategy.com/2009/02/27/netapp-cache-pcs/. The TR I mentioned is marked confidential so you have to look it up on field portal; but blog above sums up this TR just fine.

Re: Unable to enable PCS on FAS3050

Hi,

I just looked at the TR doc you are referring to & it clearly says:

You can enable PCS with a simple command line option on storage controllers with more than 2GB of system memory. To enable PCS you must be running Data ONTAP 7.2.6.1 or later:
Data ONTAP 7.2.6.1 and later 7.2.x releases
“options ext_cache.enable on”
Data ONTAP 7.3 and later
“options flexscale.enable pcs”
NOTE: For the remainder of this document, we will use the Data ONTAP 7.3 syntax. You may replace “flexscale” with “ext_cache” for PCS on Data ONTAP 7.2.6.x releases.

In other words it doesn't look like the functionality is gone, only the syntax has changed.

Regards,
Radek

Re: Unable to enable PCS on FAS3050

I have shown above that this changed syntax does not work. What am I missing? Thank you!

Re: Unable to enable PCS on FAS3050

Good question.

You may be actually right & someone (for whatever reason) decided that you can't enable PCS on a platform which cannot use PAM.

There was a bunch of people discussing similar things over here:

http://communities.netapp.com/message/9838#9838

One thing from there:

"NOTE: If you have actual PAM hardware in the system PCS won’t function. "

I don't see / know / can figure out anything else why this feature would refuse to run on FAS3050...

Re: Unable to enable PCS on FAS3050

I feel like I'm stating the obvious here....but I'd recommend putting in a support ticket if you haven't already. I'm not seeing anything you're doing wrong to be honest.....about the only thing I can think of is that on ONTap update might help (i.e. if you're running across an odd bug).