Subscribe

Unable to present LUNs from HPA Eva 4400 to gFiler

Hi

i having an issue while try to present some Array LUNs from HP Storage EVA 4400 to a NetApp gfiler v6040A

Does anybody have an experience with this hardware configuration?

I have two adapters connected to our SAN Switch Brocade SilkWorm4024 (brocade switch for hp bladecenter)

EVA and Netapp zoning have the following schema:

Zone1: EVA FP1 C1 -> SwitchB <- NetAppA 0a

Zone2: EVA FP2 C2->  SwitchB <- NetAppA 0c

here is the output for fcadmin channels

both 0a and 0c are configured as initiator ports

*> fcadmin channels

500a0982000352df 0a               N-port  (GIHAID:  7, Peer WWN: 201400051eaecd52)

500a0983000352df 0b               L-port  (GIHAID:  8)

500a0980000352df 0c               N-port  (GIHAID:  5, Peer WWN: 201500051eaecd52)

500a0981000352df 0d               L-port  (GIHAID:  6)

2100001b328200ca 3a               L-port  (GIHAID:  1)

2101001b32a200ca 3b               L-port  (GIHAID:  2)

2100001b3282b1cb 4a               L-port  (GIHAID:  3)

2101001b32a2b1cb 4b               L-port  (GIHAID:  4)

201100051eaecd52 Switch_B:17      F-port  (Phys Port: 17, FA:  0x011100, Switch WWN: 100000051eaecd52)

201200051eaecd52 Switch_B:18      F-port  (Phys Port: 18, FA:  0x011200, Switch WWN: 100000051eaecd52)

201400051eaecd52 Switch_B:20      F-port  (Phys Port: 20, FA:  0x011400, Switch WWN: 100000051eaecd52)

201500051eaecd52 Switch_B:21      F-port  (Phys Port: 21, FA:  0x011500, Switch WWN: 100000051eaecd52)

and disk show -v displays that no disks attached to system

i appreciate for any advice

Thanks

Aggelos

Unable to present LUNs from HPA Eva 4400 to gFiler

Hi Aggelos,

Have you created a Zon between the filer and the EVA?

try creating a zone from 201400051eaecd52 to 2100001b328200ca, 2101001b32a200ca, 2100001b3282b1cb, 2101001b32a2b1cb

and from 201500051eaecd52

to 201400051eaecd52 to 2100001b328200ca, 2101001b32a200ca, 2100001b3282b1cb, 2101001b32a2b1cb

Name your zones and any alias's so you can ind them. Do you just have one switching path?

STO_VFiler_EVA4400_Zone might be one example of the zone name.

Let me know how that goes.

Unable to present LUNs from HPA Eva 4400 to gFiler

Hi,

Getting gfilers/V-Series to just "work" is not so straight forward.  Assuming you have the appropriate licenses for HP EVA storage, you might want to view the supported configurations here:

http://now.netapp.com/NOW/knowledge/docs/V-Series/supportmatrix/V-Series_SupportMatrix.pdf

You might get other configurations to work, but these are known working configurations and probably the only supported ones.

Unable to present LUNs from HPA Eva 4400 to gFiler

Hi ,

I have the following schema with one of my san switch:

zoneA

gfiler 0a-> WWN-> 50:01:43:80:02:5D:FA:29 to EVA FP1 C1 WWN -> 50:01:43:80:02:5D:FA:28

ZoneB

gfiler 0c -> WWN -> 50:01:43:80:02:5D:FA:2D to EVA FP2 WWN-> 50:01:43:80:02:5D:FA:2D

For start, i need to present luns to one of my v-filer cluster controllers... so i did a zone setup to one of the switches

Some info for HP EVA:

Controller 1
FP1 50:01:43:80:02:5D:FA:28

FP2 50:01:43:80:02:5D:FA:29

Controller2
FP1 50:01:43:80:02:5D:FA:2C

FP2 50:01:43:80:02:5D:FA:2D

IBM Data Ontap 7.3.1.1 is installed on both V-Series

it is a san switch (for HP BladeCenter) C Class "Silkworm 4024",  with an updated fimware version 6.2.0g

I think that isn't a zone issue because on EVA, gfiler adapters are present and i can create a host...

Port Zoning or WWPN are both an accepted configuration with v-series matrix

....

Unable to present LUNs from HPA Eva 4400 to gFiler

Hi,,,,

I have already review Netapp support matrix and many other documents from NetApp and IBM to implement this configuration...I have no find any information for extra licensing with EVA.

Did you?

Thanks

Unable to present LUNs from HPA Eva 4400 to gFiler

Have you created the HOst on the EVA?

You will need to create the host with the wwpn ports so that you can present a lun to the netapp server. The lun will show up with the switch name.

Unable to present LUNs from HPA Eva 4400 to gFiler

0A & 0C need to ne mapped on the EVA.

Re: Unable to present LUNs from HPA Eva 4400 to gFiler

Hi Scott,,

thanks for your free time...

As you can see i have two initiators 0a and 0c from VFilerB and 2 target ports from EVA connected to

ports 17-18 (eva) and 20-21 (vfiler) on my san switch...

this are the wwn's

17  17   id    4G   Online           F-Port  50:01:43:80:02:5d:fa:29

18  18   id    4G   Online           F-Port  50:01:43:80:02:5d:fa:2d

19  19   id    4G   Online           F-Port  50:01:10:a0:00:93:9e:88

20  20   id    4G   Online           F-Port  50:0a:09:82:00:03:52:df

21  21   id    4G   Online           F-Port  50:0a:09:80:00:03:52:df

I have try to setup port zoning with no luck to show disks and there is no information from San switch present on fcadmin channels output. With port zoning also, WWNs for N ports on VFiler found as 0000000000000 and there is no other information present for additional ports on my san switch..

i have also try to mix wwn and port zoning....

zone:  VFilerB_EVA4400_ZoneA

                20:14:00:05:1e:ae:cd:52 (portname for initiator port 0a vfilerB))

                20:11:00:05:1e:ae:cd:52 (portname for target port on eva Controller 1 (fp2)

                20:12:00:05:1e:ae:cd:52 (portname for target port on eva Controller 2 (fp2)

                50:0a:09:82:00:03:52:df  (wwn of initiator port 0a on VfilerB)

                50:01:43:80:02:5d:fa:29  (wwn of target port on eva controller1 (fp2)

zone:  VFilerB_EVA4400_ZoneB

                20:15:00:05:1e:ae:cd:52 (portname for initiator port 0c)

                20:11:00:05:1e:ae:cd:52 (portname for target port on eva Controller1 (fp2)

                20:12:00:05:1e:ae:cd:52 (portname for target port on eva Controller2 (fp2)

                50:0a:09:80:00:03:52:df (wwn of initiator port 0c on VfilerB)

                50:01:43:80:02:5d:fa:2d (wwn of target port on EVA (fp2)

with this configuration i can view some information for san switch:

*> fcadmin channels

500a0982000352df 0a               N-port  (GIHAID:  7, Peer WWN: 201400051eaecd52)

500a0983000352df 0b               L-port  (GIHAID:  8)

500a0980000352df 0c               N-port  (GIHAID:  5, Peer WWN: 201500051eaecd52)

500a0981000352df 0d               L-port  (GIHAID:  6)

2100001b328200ca 3a               L-port  (GIHAID:  1)

2101001b32a200ca 3b               L-port  (GIHAID:  2)

2100001b3282b1cb 4a               L-port  (GIHAID:  3)

2101001b32a2b1cb 4b               L-port  (GIHAID:  4)

201100051eaecd52 Switch_B:17      F-port  (Phys Port: 17, FA:  0x011100, Switch WWN: 100000051eaecd52)

201200051eaecd52 Switch_B:18      F-port  (Phys Port: 18, FA:  0x011200, Switch WWN: 100000051eaecd52)

201400051eaecd52 Switch_B:20      F-port  (Phys Port: 20, FA:  0x011400, Switch WWN: 100000051eaecd52)

201500051eaecd52 Switch_B:21      F-port  (Phys Port: 21, FA:  0x011500, Switch WWN: 100000051eaecd52

there is a message on vfiler:

Mon Jun  6 14:06:27 GMT [shelf.config.unknown:info]: System storage configuration is unknown

no disk show

I have setup a host on EVA with portnames 201400051eaecd52 and 201500051eaecd52. Only WWNs

500a0982000352df and 500a0980000352df found automatically... so i add the portnames manual...

I create a lun with san solaris type, and present the LUN with Default "Automatically" WWN style, and select  LUN ID 1 and OS UNIT to 1.

disk not presented..

..........

......................

Re: Unable to present LUNs from HPA Eva 4400 to gFiler

Hi,

not sure if im reading this correctly:

zone: VFilerB_EVA4400_ZoneA

20:14:00:05:1e:ae:cd:52 (portname for initiator port 0a)

20:11:00:05:1e:ae:cd:52 (portname for target port on eva Controller 1 (fp2)

20:12:00:05:1e:ae:cd:52 (portname for target port on eva Controller 2 (fp2)

50:0a:09:82:00:03:52:df (wwn of initiator port 0a on VfilerB)

50:01:43:80:02:5d:fa:29 (wwn of target port on eva controller1 (fp2)

This means one port of the netapp filer sees 4 ways (4 ports) to the EVA SAN, this is NOT ok. NetApp allows 2 pathes to a "disk" (or array lun) max!

Oh and if the system has been configured to allow netapp native shelves, ports might be blocked for array luns:

setenv fc-non-array-adapter-list 0a,0c

So you need to do a printenv on LOADER prompt and check for that value.

Regards

Thomas

Re: Unable to present LUNs from HPA Eva 4400 to gFiler

Hi,

If you read this again, it is 1 initiator port wwpn from VfilerB in the same zone with HP Controller 1 and HP Controller 2 FP2 target adapters wwpn

so is 1 path from vfiler to each one port (total 2) on eva Controller 1 and Controller 2