Subscribe
Accepted Solution

fcp start: Partner WWNN must match local WWNN to start FCP

NetApp Release 7.3.6P2 (FAS3020c)

 

I'm having trouble starting the FCP. It says "fcp start: Partner WWNN must match local WWNN to start FCP".

 

This system used to be a cluster but has been decommissioned recently and moved to PreProd environment. There's only one Disk shelf (DS14MK2 FC) connected to the controller (Stand-alone)

Here's the current setup:

 

 

*>fcadmin config

Local
Adapter Type State Status
---------------------------------------------------
0a initiator CONFIGURED. online
0b initiator CONFIGURED online
0c target CONFIGURED offline
0d target CONFIGURED offline

 

0a is connected to ESH Module A

0b is connected to ESH Module B

0c is connected to a SAN Fabric

0d is connected to a SAN Fabric

 

I entered into "Special Boot Menu" and chose "4a" to initialize the entire system but still it didn't let me start the FCP. I even tried changing the "nodename", after adding the FCP license (KB ID: 2013604)  I tried with the below config too,

 

0a is connected to ESH Module A

0c is connected to a SAN Fabric

0d is connected to a SAN Fabric

 

Nothing made a difference. Any suggestions?

 

I can't follow KB ID: 2010727, as I don't have access to the partner controller anymore. 

 

https://library.netapp.com/ecmdocs/ECMM1278252/html/cluster/failing_over/task/t_oc_fo_mng-unconfig-hw.html#t_oc_fo_mng-unconfig-hw - This didn't work either.

 

Re: fcp start: Partner WWNN must match local WWNN to start FCP

could you try the following?

 

FAS3020> halt

 

once halted, from CFE prompt;

 

CFE> set-defaults

CFE> unsetenv partner-sysid

CFE> boot_ontap

 

and after booting up, 

 

what is the output of "cf status" command?

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.
Cannot find the answer you need? No need to open a support case - just CHAT and we’ll handle it for you.

Re: fcp start: Partner WWNN must match local WWNN to start FCP

I was able to run commands in CFE prompt and after booting up, here's what the "cf status" says,

 

Cluster must be licensed and the system rebooted before using this command.

 

 

*>fcp start
fcp start: Partner WWNN must match local WWNN to start FCP under Single Image

Re: fcp start: Partner WWNN must match local WWNN to start FCP

That means the system still thinks that its part of an HA pair. :-(

 

What does the following command command say?

 

controller> fcp show cfmode

 

is it saying 
fcp show cfmode: System is not clustered. Unable to show cfmode.

or 

is it still showing "single_image" ?

 

Also, please make sure that the NVRAM card is in slot #1, not in slot#3.

You may check this with the command: (last character is the  number one)

controller> sysconfig -a 1  

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.
Cannot find the answer you need? No need to open a support case - just CHAT and we’ll handle it for you.

Re: fcp start: Partner WWNN must match local WWNN to start FCP

It also could be stale LUN configuration options.  KB 1013497  lists some steps to reset configuration.

 

Re: fcp start: Partner WWNN must match local WWNN to start FCP

[ Edited ]

JOSSO02 had re-initialized the system, (option 4a from boot menu), so I assume no stale LUNs.

 

@aborzenkov , thanks for the KB, its good information.

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.
Cannot find the answer you need? No need to open a support case - just CHAT and we’ll handle it for you.

Re: fcp start: Partner WWNN must match local WWNN to start FCP

Right. In this case it most probably NVRAM slot.

Re: fcp start: Partner WWNN must match local WWNN to start FCP

Are we expecting a below output from sysconfig -a 1? The below output is from another stand-alone production system.

 

*> sysconfig -a 1
slot 1: NVRAM (NetApp NVRAM V)
Revision: B1
Serial Number: 534607
Memory Size: 512 MB
Battery Status: OK (4032 mV)
Charger Status: OFF
Running Firmware: 7 (3.5.0)
Cluster Interconnect Port 1: disconnected
Cluster Interconnect Port 2: disconnected
memory mapped I/O base 0xa1800000, size 0x100000
prefetchable memory base 0xa1000000, size 0x800000
prefetchable memory base 0x80000000, size 0x20000000

 

*> sysconfig -a 3
sysconfig: No such slot 3

Re: fcp start: Partner WWNN must match local WWNN to start FCP

yes , this is what is required for standalone system.

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.
Cannot find the answer you need? No need to open a support case - just CHAT and we’ll handle it for you.

Re: fcp start: Partner WWNN must match local WWNN to start FCP

Moving the NVRAM back to Slot 1 did the trick. Thanks guys for your precius time and sharing your knowledge. It was much appreciated.

 

> fcp show cfmode
fcp show cfmode: System is not clustered. Unable to show cfmode.

 

> sysconfig -a 1
slot 1: NVRAM (NetApp NVRAM V)
Revision: B1
Serial Number: 542735
Memory Size: 512 MB
Battery Status: OK (4032 mV)
Charger Status: OFF
Running Firmware: 7 (3.5.0)
Cluster Interconnect Port 1: disconnected
Cluster Interconnect Port 2: disconnected
memory mapped I/O base 0xa1800000, size 0x100000
prefetchable memory base 0xa1000000, size 0x800000
prefetchable memory base 0x80000000, size 0x20000000


> sysconfig -a 3
slot 3: Quad 10/100/1000 Ethernet Controller VII
e3a MAC Address: 00:1b:21:12:ad:f0 (auto-unknown-cfg_down)
e3b MAC Address: 00:1b:21:12:ad:f1 (auto-unknown-cfg_down)
e3c MAC Address: 00:1b:21:12:ad:f2 (auto-unknown-cfg_down)
e3d MAC Address: 00:1b:21:12:ad:f3 (auto-unknown-cfg_down)
Device Type: Rev 3, PBA D30273-005
memory mapped I/O base 0xa0540000, size 0x20000
memory mapped I/O base 0xa0500000, size 0x40000
I/O base 0x0000efc0, size 0x40
memory mapped I/O base 0xa0560000, size 0x20000
I/O base 0x0000ef40, size 0x40
memory mapped I/O base 0xa0580000, size 0x20000
I/O base 0x0000ef80, size 0x40
memory mapped I/O base 0xa05a0000, size 0x20000
I/O base 0x0000ef00, size 0x40

 

> fcp status
FCP service is running.

 

> fcadmin config

Local
Adapter Type State Status
---------------------------------------------------
0a initiator CONFIGURED. online
0b initiator CONFIGURED online
0c target CONFIGURED online
0d target CONFIGURED online