Subscribe

hw_assist Error Messages

IHAC who receives the following error messages from FAS3170A(XXX01, YYY02).

------------------------------------

Thu Nov 25 11:21:00 JST [XXX01: cf.hwassist.notifyCfgFailed:CRITICAL]: Failed to notify hardware-assist

configuration to hardware module (RLM): RLM status unknown(4)

Thu Nov 25 11:21:00 JST [XXX01:rlm.driver.timeout:warning]: The software driver for the Remote LAN Module (RLM) detected a

problem: RLM status unknown.

Mon Nov 29 17:22:16 JST [YYY02: cf.hwassist.notifyCfgFailed:CRITICAL]: Failed to notify hardware-assist configuration to hardware module (RLM): RLM status unknown(4)

Mon Nov 29 17:22:16 JST [YYY02: rlm.driver.timeout:warning]: The software driver for the Remote LAN Module (RLM) detected a problem: RLM status unknown.

-------------------------------------------------------------

As far as I can see, RLM and hw_assist seem to be configured properly.

The IP of VIF isn’t available in cf.hw_assist.partner.address option?

I’d appreciate any advice

=== hw_assist status, test ===

XXX01> cf hw_assist status

Local Node(XXX01) Status:

        Active: XXX01 monitoring alerts from partner(YYY02)

        port 4444 IP address 10.154.196.37

Partner Node(YYY02) Status:

        Active: YYY02 monitoring alerts from partner(XXX01)

        port 4444 IP address 10.154.196.38

XXX01>

XXX01> cf hw_assist test

cf hw_assist: test command successful.

YYY02> cf hw_asssist status

Local Node(YYY02) Status:

        Active: YYY02 monitoring alerts from partner(XXX01)

        port 4444 IP address 10.154.196.38

Partner Node(XXX01) Status:

        Active: XXX01 monitoring alerts from partner(YYY02)

        port 4444 IP address 10.154.196.37

YYY02>

YYY02> cf hw_assist test

cf hw_assist: test command successful.

===

=== RLM Status ===

XXX01> rlm status

        Remote LAN Module           Status: Online

                Part Number:        110-00154

                Revision:           A0

                Serial Number:      950749

                Firmware Version:   4.0

                Mgmt MAC Address:   00:A0:98:28Smiley Very Happy5:6B

                Ethernet Link:      up, 100Mb, full duplex, auto-neg complete

                Using DHCP:         no

        IPv4 configuration:

                IP Address:         10.154.196.35

                Netmask:            255.255.252.0

                Gateway:            10.154.199.254

        IPv6 configuration:         Disabled

YYY02> rlm status

        Remote LAN Module           Status: Online

                Part Number:        110-00154

                Revision:           A0

                Serial Number:      950965

                Firmware Version:   4.0

                Mgmt MAC Address:   00:A0:98:28Smiley Very Happy5:2F

                Ethernet Link:      up, 100Mb, full duplex, auto-neg complete

                Using DHCP:         no

        IPv4 configuration:

                IP Address:         10.154.196.36

                Netmask:            255.255.252.0

                Gateway:            10.154.199.254

        IPv6 configuration:         Disabled

===

=== Network Config ===

XXX01> ifconfig -a

e0M: flags=0x2108866<BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

        ether 00:a0:98:27:ee:32 (auto-unknown-cfg_down) flowcontrol full

e0a: flags=0xad48867<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

        ether 02:a0:98:27:ee:32 (auto-1000t-fd-up) flowcontrol full

        trunked vif11

e0b: flags=0xad48867<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

        ether 02:a0:98:27:ee:32 (auto-1000t-fd-up) flowcontrol full

        trunked vif11

e1a: flags=0x8bd0a867<BROADCAST,RUNNING,MULTICAST,TCPCKSUM,VLAN> mtu 9000

        ether 02:a0:98:27:ee:30 (auto-10g_sr-fd-up) flowcontrol full

        trunked vif10

e1b: flags=0x350a866<BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

        ether 00:07:43:06:e2:74 (auto-unknown-cfg_down) flowcontrol full

e2a: flags=0x8bd0a867<BROADCAST,RUNNING,MULTICAST,TCPCKSUM,VLAN> mtu 9000

        ether 02:a0:98:27:ee:30 (auto-10g_sr-fd-up) flowcontrol full

        trunked vif10

e2b: flags=0x350a866<BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

        ether 00:07:43:06:e2:52 (auto-unknown-cfg_down) flowcontrol full

lo: flags=0x1948049<UP,LOOPBACK,RUNNING,MULTICAST,TCPCKSUM> mtu 8160

        inet 127.0.0.1 netmask-or-prefix 0xff000000 broadcast 127.0.0.1

        ether 00:00:00:00:00:00 (VIA Provider)

vif11: flags=0x22d48863<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

        inet 10.154.196.37 netmask-or-prefix 0xfffffc00 broadcast 10.154.199.255

        partner vif11 (not in use)

        ether 02:a0:98:27:ee:32 (Enabled virtual interface)

vif10: flags=0xa3d0a863<BROADCAST,RUNNING,MULTICAST,TCPCKSUM,VLAN> mtu 9000

        partner vif10 (not in use)

        ether 02:a0:98:27:ee:30 (Enabled virtual interface)

vif10-2409: flags=0x394a863<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 9000

        inet 10.154.207.129 netmask-or-prefix 0xffffffc0 broadcast 10.154.207.191

        partner vif10-2409 (not in use)

        ether 02:a0:98:27:ee:30 (Enabled virtual interface)

        nfo enabled

vif10-2410: flags=0x394a863<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 9000

        inet 10.154.207.193 netmask-or-prefix 0xffffffc0 broadcast 10.154.207.255

        partner vif10-2410 (not in use)

        ether 02:a0:98:27:ee:30 (Enabled virtual interface)

YYY02> ifconfig -a

e0M: flags=0x2108866<BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

        ether 00:a0:98:27:e9:a6 (auto-unknown-cfg_down) flowcontrol full

e0a: flags=0xad48867<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

        ether 02:a0:98:27:e9:a6 (auto-1000t-fd-up) flowcontrol full

        trunked vif11

e0b: flags=0xad48867<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

        ether 02:a0:98:27:e9:a6 (auto-1000t-fd-up) flowcontrol full

        trunked vif11

e1a: flags=0x8bd0a867<BROADCAST,RUNNING,MULTICAST,TCPCKSUM,VLAN> mtu 9000

        ether 02:a0:98:27:e9:a4 (auto-10g_sr-fd-up) flowcontrol full

        trunked vif10

e1b: flags=0x350a866<BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

        ether 00:07:43:06:e1:99 (auto-unknown-cfg_down) flowcontrol full

e2a: flags=0x8bd0a867<BROADCAST,RUNNING,MULTICAST,TCPCKSUM,VLAN> mtu 9000

        ether 02:a0:98:27:e9:a4 (auto-10g_sr-fd-up) flowcontrol full

        trunked vif10

e2b: flags=0x350a866<BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

        ether 00:07:43:06:e2:5c (auto-unknown-cfg_down) flowcontrol full

lo: flags=0x1948049<UP,LOOPBACK,RUNNING,MULTICAST,TCPCKSUM> mtu 8160

        inet 127.0.0.1 netmask-or-prefix 0xff000000 broadcast 127.0.0.1

        ether 00:00:00:00:00:00 (VIA Provider)

vif11: flags=0x22d48863<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

        inet 10.154.196.38 netmask-or-prefix 0xfffffc00 broadcast 10.154.199.255

        partner vif11 (not in use)

        ether 02:a0:98:27:e9:a6 (Enabled virtual interface)

vif10: flags=0xa3d0a863<BROADCAST,RUNNING,MULTICAST,TCPCKSUM,VLAN> mtu 9000

        partner vif10 (not in use)

        ether 02:a0:98:27:e9:a4 (Enabled virtual interface)

vif10-2409: flags=0x394a863<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 9000

        inet 10.154.207.130 netmask-or-prefix 0xffffffc0 broadcast 10.154.207.191

        partner vif10-2409 (not in use)

        ether 02:a0:98:27:e9:a4 (Enabled virtual interface)

vif10-2410: flags=0x394a863<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 9000

        inet 10.154.207.194 netmask-or-prefix 0xffffffc0 broadcast 10.154.207.255

        partner vif10-2410 (not in use)

        ether 02:a0:98:27:e9:a4 (Enabled virtual interface)

        nfo enabled

===

Thanks

Makoto Yoshida

Re: hw_assist Error Messages

Hi

1. Please check network interfaice e0m up???

2.If not - ifconfig e0m up

If not

Change options.cf.assist address from e0m interfaice to e0a.

Example

ifconfig -a

e0M: flags=0x2108866<BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

        ether 00:a0:98:27:ee:32 (auto-unknown-cfg_down) flowcontrol full

e0a: flags=0xad48867<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

        ether 02:a0:98:27:ee:32 (auto-1000t-fd-up) flowcontrol full

options

cf.hw_assist.enable on
Change cf.hw_assist.partner.address xxxx (IP address e0a)
cf.hw_assist.partner.port 4444

Check

cf hw_assist status

cf hw_assist test

Re: hw_assist Error Messages

Thank you for replying.

RLM is configured, but e0M isn't configured.

e0a is a part of vif named 'vif11'.

cf.hw_assist.partner.address is currently set the ip of vif11.

cf.hw_assist.partner.address accepts only e0M or e0a?

The IP of vif isn't supported on cf.hw_assist.partner.address option?

Re: hw_assist Error Messages

Note: RLM is required.

If filer is in a clustered state, go to one of the filers and issue the  command to check the current status:

>cf hw_assist status

Local Node(netapp1) Status:
  Inactive: filera not monitoring alerts  from partner(filerb)
  Fail to bind UDP socket to port 4444 IP address  10.61.69.125

To configure hw_assist, you will need to determine  which interface you will use for the configuration. Interface e0m is preferred  when setting up hw_assist to separate traffic, but e0a is the default if e0m is  not configured and online. If you will be using e0a, you will need to make sure  name resolution is working. No additional configuration is needed to use  e0m.

  1. Determine the interface to use:

        filera> ifconfig  -a
        e0M: flags=948043 mtu 1500
        inet 10.61.69.122 netmask 0xffffff00  broadcast 10.61.69.255
      partner e0M (not in use)
      ether  00:a0:98:0c:3d:a6 (auto-100tx-fd-up) flowcontrol full
        e0a: flags=948043  mtu 1500
        inet 10.61.69.120 netmask 0xffffff00 broadcast 10.61.69.255
       ether 00:a0:98:0c:3d:a4 (auto-1000t-fd-up) flowcontrol full

         filerb> ifconfig -a
        e0M: flags=948043 mtu 1500
        inet  10.61.69.127 netmask 0xffffff00 broadcast 10.61.69.255
      partner e0M (not in  use)
      ether 00:a0:98:0c:40:3e (auto-100tx-fd-up) flowcontrol full
         e0a: flags=108042 mtu 1500
        inet 10.61.69.125 netmask 0xffffff00 broadcast  10.61.69.255
      ether 02:a0:98:0c:40:3e (auto-1000t-fd-up) flowcontrol  full
  2. Turn on hw_assist on for both heads (if needed):
      > options  cf.hw_assist.enable on
  3. Set the partner address for hw_assist:
      filera> options  cf.hw_assist.partner.address 10.61.69.127
      Validating the new hw-assist  configuration. Please wait...
      filera>
      filerb> options  cf.hw_assist.partner.address 10.61.69.122
      Validating the new hw-assist  configuration. Please wait...
      filerb>
  4. Set the hw_assist port for both heads (if needed):
      > options  cf.hw_assist.partner.port 4444
      Validating the new hw-assist configuration.  Please wait...
      >
  5. Check hw_assist status for both heads (may take a few minutes):
        filera> cf hw_assist status
      Local Node(filera) Status:
      Active:  filera monitoring alerts from partner(filerb)
      port 4444 IP address  10.61.69.122
      Partner Node(filerb) Status:
      Active: filerb monitoring  alerts from partner(filera)
      port 4444 IP address 10.61.69.127

         filerb> cf hw_assist status
      Local Node(filerb) Status:
      Active:  filerb monitoring alerts from partner(filera)
      port 4444 IP address  10.61.69.127
      Partner Node(filera) Status:
      Active: filera monitoring  alerts from partner(filerb)
      port 4444 IP address 10.61.69.122

The status will not change to monitoring alerts from the partner until the  next keep alive ping has been received. Once the ping has been received, the  status will change to active for both the local and partner node.

As an alternative, test the configuration with the test command:
   > cf hw_assist test
    cf hw_assist: test command successful