Subscribe

lun is not accessible in windows 2008 R2 server

I have a LUN from NetApp FAS6040 that I have attached to a windows server 2008 R2 and I cannot access the LUN in windows.

Each time I try to open the LUN in wondows, it tells me access denied.

Has anyone come across this problem before?

Please any valuable advice will be highly appreciated.

Regards

Ejiro

Re: lun is not accessible in windows 2008 R2 server

You may need to provide a bit more information but things to check.

1. Physical fibre / network connection and switch zoning or config.

2. Is snapdive running as an account with enough rights to the domain the filer is in (used to domain admin, but is less now)

3. Config on the filer ie the Initiator Groups

Re: lun is not accessible in windows 2008 R2 server

Thanks for your response

The volume cretaed is /vol/ejiro

Inside this volume I have have three luns namely;

/vol/ejiro/lun1

/vol/ejiro/lun2

/vol/ejiro/lun3

I have mapped the three luns to same windows server 2008 machine.

On the windows server 2008 machine, I can access /vol/ejiro/lun1 and /vol/ejiro/lun2

But I cannot access /vol/ejiro/lun3.

Each time I double click on it,

"It tells me access denied"

There is no snap drive installed

This is an iscsi lun for windows

There is no fibre connection

I am using my local ethernet network for the connection

I only have one initiator group with one iqn member

Re: lun is not accessible in windows 2008 R2 server

Hello,

Have you tried to remove the lun and remapp again?

Maybe you should try to create another lun be sure to choose windows (and not other OS) in lun creation

and mapp again

Re: lun is not accessible in windows 2008 R2 server

OK, I appreciate it is pretty basic & you might have done it already, but maybe worth asking:

What happens if you go on your win2k8 host to Computer > Management > Storage > Disk Management? Can you see the LUN in question? Does it appear as uninitialized by any chance? Can you initialize it?

Failing that, did you try diskpart on your host? What does it say?

Regards,
Radek

Re: lun is not accessible in windows 2008 R2 server

Hi All,

I have found a solution to the challenge.

I cloned the lun, split it fromt he parent lun and mapped it to the same server.

And that was it.

Problem solved.

Thanks for all your wonderful suggestions

Regards

Ejiro