Subscribe

netapp FAS2020 virtual interface and Cisco VLAN's

Hello,

Is there any recommendation from netapp how to setup a cisco switch using Vlan's with virtual interfaces. I have a FAS2020 with two controllers, and two ports each connected to the Cisco switch (3750). I have configured the filer using a virtual interface (vif1) for the both network ports (e0a, e0b). All is OK, but the both controllers can't ping each other and a cluster takeover and giveback took really long (15min). When I disconnect one of the network ports of each controller (f.e. e0b), the ping between both is OK and the cluster takeover and giveback is running perfect within seconds. So, I think there is a misconfig within the Cisco switch.

Here is the switch port config:

interface GigabitEthernet1/0/47

description SMUN204 port e0b

switchport access vlan 9

switchport mode access

switchport port-security maximum 3

switchport port-security

switchport port-security aging time 2

switchport port-security violation restrict

switchport port-security aging type inactivity

spanning-tree portfast

spanning-tree bpduguard enable

end

I hope you can help me.

Thanks

Chris

Re: netapp FAS2020 virtual interface and Cisco VLAN's

It sounds like you configured multi mode VIF on NetApp, in which case you have to configure matching port channel in Cisco. Alternative is to change NetApp configuration to single mode VIF.