Subscribe

problem with hw_assist

Hi All,

I have a problem with setting up of "cf.ha_assist".

when try to start command cf.ha_assist test, i have this output:

cf hw_assist Error: No response from partner(XXXX), timed out.

i use the e0M interface for cf.ha_assist.

from the cf hw_assist status command i see this output:

Thu Jul 10 22:14:46 CEST [IXXX:cf.hwassist.Default.NodemgmtAddr:notice]: The system automatically chose 192.168.X.X as the local hardware-assist IP address. 

Thu Jul 10 22:15:07 CEST [XXX:cf.hwassist.socBindFailed:error]: hw_assist: bind failed to port 4444 on IP address 192.168.X.X Error 49

the netapp system is Fas2240-4 with data ontap 8.2.1

can you help me ?

thanks for support

Regards

Antonio


Re: problem with hw_assist

Did you set up your SP properly?

Re: problem with hw_assist

I don't know your rc file setup, but whats wrong with using your filers vif ip

Re: problem with hw_assist

please share the "options cf" command output.

problem with hw_assist

Hi All, soory for delay,

follow the output of "options cf":

first node:

cf.giveback.auto.after.panic.takeover on        

cf.giveback.auto.cancel.on_network_failure on        

cf.giveback.auto.cifs.terminate.minutes 5         

cf.giveback.auto.delay.seconds 600       

cf.giveback.auto.enable      off       

cf.giveback.auto.override.vetoes off       

cf.giveback.check.partner    on        

cf.hw_assist.enable          off       

cf.hw_assist.partner.address 192.168.X.Y

cf.hw_assist.partner.port    4444      

cf.mode                      ha        

cf.remote_syncmirror.enable  off        (same value required in local+partner)

cf.sfoaggr_maxtime           120        (value might be overwritten in takeover)

cf.takeover.bypass_optimization off       

cf.takeover.change_fsid      on        

cf.takeover.detection.seconds 15        

cf.takeover.on_disk_shelf_miscompare off       

cf.takeover.on_failure       on        

cf.takeover.on_network_interface_failure on        

cf.takeover.on_network_interface_failure.policy all_nics   (same value in local+partner recommended)

cf.takeover.on_panic         on        

cf.takeover.on_reboot        off       

cf.takeover.on_short_uptime  on        

cf.takeover.use_mcrc_file    off 

second node:

cf.giveback.auto.after.panic.takeover on        

cf.giveback.auto.cancel.on_network_failure on        

cf.giveback.auto.cifs.terminate.minutes 5         

cf.giveback.auto.delay.seconds 600       

cf.giveback.auto.enable      off       

cf.giveback.auto.override.vetoes off       

cf.giveback.check.partner    on        

cf.hw_assist.enable          off       

cf.hw_assist.partner.address 192.168.X.Y

cf.hw_assist.partner.port    4444      

cf.mode                      ha        

cf.remote_syncmirror.enable  off        (same value required in local+partner)

cf.sfoaggr_maxtime           120        (value might be overwritten in takeover)

cf.takeover.bypass_optimization off       

cf.takeover.change_fsid      on        

cf.takeover.detection.seconds 15        

cf.takeover.on_disk_shelf_miscompare off       

cf.takeover.on_failure       on        

cf.takeover.on_network_interface_failure on        

cf.takeover.on_network_interface_failure.policy all_nics   (same value in local+partner recommended)

cf.takeover.on_panic         on        

cf.takeover.on_reboot        off       

cf.takeover.on_short_uptime  on        

cf.takeover.use_mcrc_file    off 

thanks