Subscribe
Accepted Solution

snapmirror throttle option not working

I would like to set the snapmirror throttle for just one snapmirror between two filers.  {This is the seed transfer}

FAS2050, Dot 7.2.4L1  -->  FAS3070 7.3.1P3

I have configured the snapmirror.conf file

#Regenerated by registry Tue Nov  3 10:10:49 GMT 2009
SAN01:dmfil01 SAN012:dmfil01 kbs=5120 - - - -

However it does not work and it is maxing out my WAN link.  Is the a bug between filer version, throttling does not work on the seed or I have type the comand wrong?

Thanks for the help.

Bren

Re: snapmirror throttle option not working

Hmm, I've found settings defined in snapmirror.conf file being ignored sometimes without any logical reason.

Did you try to use CLI command instead?

snapmirror intialize -S SAN01:dmfil01 -k 5120 SAN012:dmfil01

Regards,
Radek

Re: snapmirror throttle option not working

...and BTW - what's your total WAN bandwidth? 5Mbit seems like a pretty generous allowance, so maybe it does actually work?

Re: snapmirror throttle option not working

Yes that is working now thankyou.  Wish I had through of trying that myself.  Filerview is getting quite flaky now.  Had an issue yesterday when trying to grow an aggregate.  Filerview could not 'see' the new disks.  Had to use aggr add to make it work. 

Bren

Re: snapmirror throttle option not working

Yeah, FilerPoo requires urgent facelift

Have you played with System Manager?

Not for everyone  though, as it doesn't support 6000 series:

http://now.netapp.com/NOW/knowledge/docs/olio/guides/system_manager/system_manager_matrix.shtml

Re: snapmirror throttle option not working

Can not use SM as it does not manage snapmirrors yet. It is a nice product however.

Re: snapmirror throttle option not working

Can not use SM as it does not manage snapmirrors yet.

...which brings us back to square one - CLI rules!

Re: snapmirror throttle option not working

Keep in mind, that kbs means kiloBYTES per second. If you want 5120 kiloBITS per second, divide by 8 and try again.

In my experience the throttling works very well, both in snapmirror.conf and using the replication options.

-- Adam Fox

Re: snapmirror throttle option not working

Keep in mind, that kbs means kiloBYTES per second.

Sweet. I actually missed that small-ish issue

So basically Bren was capping roughly at 40Mbit/sec - not a big suprise WAN link got a 'bit' busy...

Re: snapmirror throttle option not working

This is a really bad oversight.  "kbps" with a lowercase 'b' universally means bits, not bytes.  This is almost as bad as saying that "TB" means "terabits," except miscalculating storage size won't saturate a production WAN link.