Subscribe
Accepted Solution

Alta Vault using shell instead of CLI mode

[ Edited ]

hello

 

I'm new to Alta Vault. I have issue with evicter configuration (maxpctused, upperbound, alarmwindow). I'm using CLI where command lines like the one below are not recognized:

 

rfsctl -Sw evicter.maxpctused=90
% Unrecognized command "-Sw".
Type "rfsctl ?" for help.

 

I assume it can be done using shell, but I can't find a way to switch between CLI and shell mode. I'm using AltaVault varsion 4.2.2

 

 

I would be very grateful for your help in this matter.

Re: Alta Vault using shell instead of CLI mode

Hi,

rfsctl is no longer user accessible (shell is not available to users either), and you will need to issue commands as documented in the AltaVault CLI guide. For setting the eviction threshold, you should issue the 'datastore eviction threshold' command (default value is 90%). Alarms that can be adjusted are displayed in the alarms page in the UI (Configure > Alarms).

 

Regards,

Christopher

Re: Alta Vault using shell instead of CLI mode

Hello Christopher and thanks for your answer

 

 

I'm able to modify eviction threshold (victer.maxpctused) using CLI, but I'm wondering if when setting the evictor threshold to arbitrary values we should also adjust evicter.alarmwindow in order to keep equation balanced:

 

evicter.upperbound=evicter.maxpctused + evicter.alarmwindow

 

Best Regards

 

 

 

Re: Alta Vault using shell instead of CLI mode

Hi,

The rfsctl is not available beyond support to modify any other settings on AltaVault, and therefore you do not have access to configure any other evictor settings beyond the one already discussed (setting the eviction %). 

 

Regards,

Christopher