Subscribe
Accepted Solution

Disable lun space reservation.

I tried using set-nclunattribute for IsSpaceReservationEnabled to false it it doesn't seem to work. Is this the right cmdlet to do this? 


In the web console you would go to SVM,storage,luns, click edit on any lun and choose the checkbox for disable space reservation.

Re: Disable lun space reservation.

Hello @ijustwantthemodule

 

LUN attributes are different than you might expect, they allow the setting of arbitrary metadata about the LUN.  You want the "Set-NcLunSpaceReserved" cmdlet:

 

# set the LUN to thin provisioned
Get-NcLun $lunName | Set-NcLunSpaceReserved -Off

# set the LUN to thick provisioned
Get-NcLun $lunName | Set-NcLunSpaceReserved

Hope that helps.

 

Andrew

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.