Subscribe
Accepted Solution

Get-NaEfficiency (TotalLunSize and OverProvisioningPercent) commands aren't working properly

[ Edited ]

Hi all ,

 

Get-NaEfficiency   (TotalLunSize and OverProvisioningPercent) commands aren't working properly

 

 

vol1 : 100g (thin)

vol2 : 100g (thick)

 

lun1 : /vol/vol1/lun1    , 150g(thin)

lun2 : /vol/vol2/lun1    , 50g(thick)

 

 

(Get-NaEfficiency vol1).TotalLunSize  is "0"

(Get-NaEfficiency vol1).OverProvisioningPercent is  "0"

(Get-NaEfficiency vol2).TotalLunSize  is "0"

(Get-NaEfficiency vol2).OverProvisioningPercent is  "0"

 

 

 

 TotalLunSize:  Total size of all the LUNs contained within this volume.  This value is only valid when the -Recurse switch is present.

 OverProvisioningPercent: The LUN over-provisioning percent of the volume.  This value is equal to (TotalLunSize / Capacity) * 100.  This value is only valid when the -Recurse switch is present.

 

 

 

 

 

But it must be different value.

 

do you have any idea ?

 

 

Re: Get-NaEfficiency (TotalLunSize and OverProvisioningPercent) commands aren't working properly

You'll need to use the "-Recurse" switch for those values to be populated:

 

(Get-NaEfficiency vol1 -Recurse).TotalLunSize
(Get-NaEfficiency vol2 -Recurse).TotalLunSize

Andrew

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Highlighted

Re: Get-NaEfficiency (TotalLunSize and OverProvisioningPercent) commands aren't working properly

Thank you asulliva