Subscribe
Accepted Solution

Get-naaggr issue pulling back info

Anyone else running into this issue?

If I do a get-naaggr. I get back:

Name            State       TotalSize  Used  Available Disks RaidType RaidSize MirrorStatus     FilesUsed FilesTotal
----            -----       ---------  ----  --------- ----- -------- -------- ------------     --------- ----------
aggr0           online       855.0 MB   95%    40.6 MB   3   raid_dp     16    unmirrored              96        30k
aggr1           online         7.0 GB    0%     7.0 GB  10   raid_dp     16    unmirrored              96        31k
aggr2           online        31.6 GB   38%    19.6 GB  42   raid_dp     16    unmirrored              96        31k

But if I try to select just a few fields, the data doesn't show up.

For example:

get-naaggr | select Name, State, TotalSize, Used, Disks, MirrorStatus

Results in:


Name         : aggr0
State        : online
TotalSize    :
Used         :
Disks        :
MirrorStatus : unmirrored

Name         : aggr1
State        : online
TotalSize    :
Used         :
Disks        :
MirrorStatus : unmirrored

Name         : aggr2
State        : online
TotalSize    :
Used         :
Disks        :
MirrorStatus : unmirrored

No TotalSize, Used or Disks information comes back.

Anyone running into this?

Re: Get-naaggr issue pulling back info

For many of the objects returned by the toolkit, the table column headers do not map directly to a field name.  Doing a Get-NaAggr | fl * will show you what the "real" field names are.  The next version of the toolkit will include the proper aliases so you can use the table column header names to access these fields.

Hope that helps,

Steven

Re: Get-naaggr issue pulling back info

I love how active the powershell community is. Thanks for the info!