Subscribe
Accepted Solution

Invoke-NcSsh failing with ONTAP 9.3

 I have just upgrade a lab controller to 9.3 so I could test some deployment scripts. Part of my scripts issue "Invoke-NcSsh" commands because a commandlet is not working as intended or does not exsist. I had originally thought it was an issue with the 4.4 verion of the powershell toolkit. I upgraded to 4.5 and I am still getting the same error.  See error below:

 

 

"Invoke-NcSsh : An established connection was aborted by the software in your host machine."

 

Everything works from 9.0 - 9.2P1, but not in 9.3.

 

Any help would be great. 

Re: Invoke-NcSsh failing with ONTAP 9.3

Good catch, I can confirm i'm seeing the same thing in 9.3RC1 as well.  I assume when I upgrade our lab to GA, it will be the same thing.

 

My error is this.

invoke-ncssh : An established connection was aborted by the software in your host machine.

 

We are probably just missing a new security setting in 9.3 that needs to be tweaked..

Re: Invoke-NcSsh failing with ONTAP 9.3

I am hoping that is the case. I am working now to re-write the commands with current cmdlets and a lot of piping. 

Re: Invoke-NcSsh failing with ONTAP 9.3

Curious if anyone else has experienced this and maybe found a work around or a security change that is needed. 

Re: Invoke-NcSsh failing with ONTAP 9.3

Hello everyone,

 

I verified this behavior yesterday and created a bug for it (1136301).

 

Please let me know if I can help!

 

Andrew

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Invoke-NcSsh failing with ONTAP 9.3

Please post when an update or workaround has been determined.

Re: Invoke-NcSsh failing with ONTAP 9.3

This would seem to be the same issue currently with 8.2.5 7-mode .... see the following post ...

 

http://community.netapp.com/t5/Microsoft-Cloud-and-Virtualization-Discussions/Invoke-NaSsh-not-working-anymore-with-DOT-8-2-5-7-mode/td-p/133511

 

There is a workaround code example in the 8.2.5 7-mode thread posted by skellner using Invoke-NaSystemAPI (page 2).  I changed the "Na" to "Nc" and it works without any other modifications.

 

While this still needs to be fixed obviously - the other post gives more details on the issue and hopefully a stop-gap workaround for most.

 

 

Re: Invoke-NcSsh failing with ONTAP 9.3

If you are affected by this, I suggest to open a support case and ask the support engineer to attach the case to the internal bug 1136301 (mentioned by Andrew). This way the customer impact is more visible to engineering and the issue can be correctly prioritized.

 

Regards

 

Hendrik