Community

Subscribe
Highlighted
Accepted Solution

NetApp OnCommand Plug-in for Microsoft, SCOM 2012 R2 and SNMP

We're running System Center Operations Manager 2010 R2, UR1 on Server 2008 R2 SP1, and have installed version 4.1.0 of the NetApp OnCommand Plug-in for Microsoft but it is not receiving SNMP traps from the controllers. We followed the install/admin guide instructions and configured SNMP on each managed storage system then enabled non-emergency trap monitors by using overrides. All the controllers show up and non-SNMP alerting appears to be working for the Management Pack, but SNMP alerts are not getting collected. We've even setup an event view based on the Data ONTAP: Controller SNMP Trap Rule and nothing ever shows up in that view when we test.

As a side note, we can receive SNMP traps from these same controllers (using a custom rule) if we setup a discovery rule for the controllers. We can then setup an even view that shows the traps coming in and SCOM receiving them. However, since OCPM isn't using the same rule, it doesn't work.

Anyone have SNMP traps working with OCPM?

Re: NetApp OnCommand Plug-in for Microsoft, SCOM 2012 R2 and SNMP

Hey Jason, please have a look at the IAG, it covers the steps to configure SNMP traps.

https://library.netapp.com/ecm/ecm_get_file/ECMP1196510

Re: NetApp OnCommand Plug-in for Microsoft, SCOM 2012 R2 and SNMP

Hi Vinith,

In my post I said that I had followed the instructions in the install/admin guide to configure SNMP. So, just to clarify, I have already done what you reference. Also, SCOM is receiving SNMP traps from other devices, so SNMP is working with SCOM. In doing some more research, I ran across this article, that seems to indicate that unless the SNMP part of the MP was updated for OpsMgr 2012, then it will not work with new installations of OpsMgr 2012. We have a fresh, new install of OpsMgr 2012 (not an upgrade) and installed OCPM. When looking under the Network Devices in SCOM we can see the controllers, but they show up as Legacy SNMP Network Devices, which, to me, would indicate that that the SNMP part for OCPM was not updated to work with OpsMgr 2012. Again, we did not upgrade to OpsMgr 2012 and we have followed all of the instructions in the Installation and Administration Guide and it is not working.

Does anyone have the SNMP part setup and working on a fresh install of OpsMgr 2012?

Re: NetApp OnCommand Plug-in for Microsoft, SCOM 2012 R2 and SNMP

Hey Jason,

Im working with our engineering team on this, i would get back to you once i get and update.

Thanks,

Vinith

Re: NetApp OnCommand Plug-in for Microsoft, SCOM 2012 R2 and SNMP

For anyone else with this same question/problem, this is broken in SCOM 2012 and is a known issue, check out BURT 823846.