Subscribe

NetApp Simulator and SCVMM 2012 RC

Has anyone had success using the OnTAP Simulator with System Center Virtual Machine Manage 2012 RC?

I've been playing around with the new process of adding providers and have continued to run into problems managing storage pools. After adding the storage provider to VMM, I am unable to add classifications, and manage any storage pools. The odd thing is, the same simulator setup works if I use SCVMM 2012 BETA.

Upon adding the provider, I receive an error code within SCVMM: HostTypeNotSupported. If I view the properties of the properties and try again, the error changes to "NO PARAM: NO PARAM."

I am currenly trying to use:

    SCVMM2012 RC Build 3.0.5007.0

    OnTAPSMI-S Agent 4.0

    NetApp OnTAPSimulator 7.3.6

I can't seem to find anyone with any insight as to why this might have broke between versions of SCVMM 2012.

Any input is appreciated!

NetApp Simulator and SCVMM 2012 RC

Hi Jeff,

Can you please provide information to below questions,

1. Please paste the output of below command from ONTAP SMIS Agent 4.0

smis <user> <passwd> list

smis <user> <passwd> version

smis <user> <passwd> luns

smis <user> <passwd> pools

smis <user> <passwd> initiators

2. Please remove the NetApp OntapSimulator instance from the ONTAP SMIS Agent 4.0 using below command and rerun the discovery at SCVMM 2012.

smis <user> <passwd> delete <ip of storage system>

Regards,

Nilesh

NetApp Simulator and SCVMM 2012 RC

Thanks for the reply.

smis <user> <passwd> list

ONTAP_FilerData.hostname="192.168.0.201",port=80

smis <user> <passwd> version

ONTAP_SMIAgentSoftware.InstanceID="ONTAP:4.0X8"

smis <user> <passwd> luns

[I have not configured any luns, output was blank]

smis <user> <passwd> pools

ONTAP_DiskPrimordialPool.InstanceID="OPTAP:0099932695:Spare"

ONTAP_DiskPrimordialPool.InstanceID="OPTAP:0099932695:Other"

ONTAP_DiskPrimordialPool.InstanceID="OPTAP:0099932695:Present"

ONTAP_ConcretePool.InstanceID="ONTAP:0099932695:b5e32440-bf3a-11de-ae7b-005056134b9a"

smis <user> <passwd> initiators

ONTAP_StorageHardwareID.InstanceID="ONTAP:0099932695:ign.1991-05.com.microsoft.vmm.contoso.com"

After removing the simulator instance from the agent, (The only instance) I retried discovery in VMM 2012 and received this error:

NetApp Simulator and SCVMM 2012 RC

Hey Jeff,

You are using an old version (an X build) of the Ontap SMIS Agent 4.0

Please download latest bits from NOW site. Let us know if you hit the same issue with the new build.

Regards,

Nilesh

NetApp Simulator and SCVMM 2012 RC

Unfortunately, this achieves the same exact result.

NetApp Simulator and SCVMM 2012 RC

Are you running the ONTAP SMIS agent on VMM.contoso.com ?

NetApp Simulator and SCVMM 2012 RC

If SCVMM is running on VMM.contoso.com then restart Microsoft Storage Management Service. This service communicates with SMIS providers. Let me know if this helps.

NetApp Simulator and SCVMM 2012 RC

I've tried running the SMI-S Agent on VMM and on another server, same thing.

I just tried restarting the Microsoft Storage Management Service and that did not help either.

Re: NetApp Simulator and SCVMM 2012 RC

Hi

I'm getting the precise same issue. The same error scenario.

I'm using OnTAP 8.02 on the FAS filer.

Restarting the service does not help and the SMI-S agent appears to connect successfully.

Any resolution to this so far? Or update on progress Jeff?

Thanks

Hari

Re: NetApp Simulator and SCVMM 2012 RC

Sorry no, I have not been able to resolve this problem.

I've been troubleshooting this for 3 weeks. Using the exact NetApp Simulator (running on Ubuntu virtual machine) with SCVMM 2012 BETA works just fine, but switching to SCVMM 2012 RC, it breaks as described above. No one seems to know why.

So you're note using a Simulator to test, but a physical device?