Subscribe

NetAppDocs breaks with ONTAP 9.1P2 ?

Has anyone else seen this? Toolkit worked fine against ONTAP 8.3.2P5, but breaks now after upgrade to 9.1P2:

 

(cluster name changed for privacy)

 


PS C:\Users\701494>
PS C:\Users\701494> Get-NtapClusterData -name 'clusterxxx' -Credential (Get-Credential admin) -Verbose
VERBOSE: Initializing function: Get-NtapClusterData (NetAppDocs v3.2.0.1759)
VERBOSE: Validating connectivity to system: clusterxxx
VERBOSE: Using supplied credentials
VERBOSE: Trying HTTP/HTTPS
VERBOSE: Connected to clusterxxx using HTTPS
VERBOSE: Skipping EMS logging

 

<clipped the bulk of verbose output>

 

VERBOSE: - Gathering debug information -

VERBOSE: Calling Invoke-NcSystemApi (set -privilege diagnostic -confirmations off; debug vreport show -instance
VERBOSE: - Getting current timestamp -
VERBOSE: - Identifying SystemName -
VERBOSE: - Identifying any errors during processing -
Format-NtapClusterData : Exception calling "Add" with "1" argument(s): "Column 'SwitchSerialNumber' does not allow
nulls."
At line:1 char:87
Get-NtapClusterData -name 'clusterxxx' -Credential (Get-Credential admin) -Verbose
+ ~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (Smiley Happy [Format-NtapClusterData], MethodInvocationException
+ FullyQualifiedErrorId : NoNullAllowedException,Format-NtapClusterData

PS C:\Users\701494>

 

Re: NetAppDocs breaks with ONTAP 9.1P2 ?

Hi David,

 

Is it possible to send me the raw output from this cluster? This isn't necessarily a 9.1P2 issue, other than the possibility of the property name being changed. The real issue is that this condition shouldn't produce a terminating error.  I will send you an email offline to discuss further.

 

Thanks,

 

Jason

Re: NetAppDocs breaks with ONTAP 9.1P2 ?

[ Edited ]

Thanks for your prompt reply Jason! Per our email exchange, the latest pre-release of NetAppDocs you provided corrected the problem! All set!

 

-dave