Subscribe

No output running Get-NtapFilerData

Hello all,

The results from Get-NtapFilerData has been working for the past 9 months.

 

I upgraded to Data ONTAP 8.2.4P4 7-Mode and now the Get-NtapFilerData command doesn't run. 

 

Here's the output (servername's have been removed).

PS C:\Windows> Get-NtapFilerData -Name 'servername-a', 'servername-a-a', 'servername-b', 'servername-b' -credential $cred | Format-NtapFilerData | Out-NtapDocument -WordFile 'c:\NetApp-Output\NetApp-System Configuration.Doc
put\NetApp-Airports System Configuration.xlsx' -CustomerName 'DTech' -CustomerLocation 'Airport'
WARNING: The Hardware-ONTAP file is out of date. An update should be downloaded from the communities site and copied to the folder: C:\windows\system32\windowspowershell\v1.0\Modules\NetAppDocs\Resources
Get-FilerData : An unexpected error occured. Processing halted.
--------------------------------------------------------------------------------------
As this error is not expected, please consider reporting it on the communities
site. (https://communities.netapp.com/groups/usps-scripts-and-tools)
--------------------------------------------------------------------------------------
Reason: Could not compare "10" to "25 35". Error: "Cannot convert the "System.Object[]" value of type "System.Object[]" to type "System.Int32"."
Location: at <ScriptBlock>, C:\windows\system32\windowspowershell\v1.0\Modules\NetAppDocs\Private_Functions\DiscoveryFunctions.ps1: line 252
at Get-NtapRemoteManagement, C:\windows\system32\windowspowershell\v1.0\Modules\NetAppDocs\Private_Functions\DiscoveryFunctions.ps1: line 252
at Get-FilerData, C:\windows\system32\windowspowershell\v1.0\Modules\NetAppDocs\Get-NtapFilerData.ps1: line 375
at Get-NtapFilerData<Process>, C:\windows\system32\windowspowershell\v1.0\Modules\NetAppDocs\Get-NtapFilerData.ps1: line 186
at <ScriptBlock>, <No file>: line 1
At C:\windows\system32\windowspowershell\v1.0\Modules\NetAppDocs\Get-NtapFilerData.ps1:186 char:33
+                     $ntapData = Get-FilerData -Controller $controller
+                                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (Smiley Happy [Write-Error], WriteErrorException
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Get-FilerData

WARNING: Empty dataset found so document generation not possible

 

Is this the correct forum to state the problem?


This URL/community/group, doesn't exist.  (https://communities.netapp.com/groups/usps-scripts-and-tools)

 

Thanks in advance for the help,
-joe-

Re: No output running Get-NtapFilerData

Hi Joe,

 

I believe this issue has been resolved in the latest 3.1P1 release. I'm assuming you are running version 2.6?

 

The community site has moved to here:

https://forums.netapp.com/community/private-spaces/netapp-partners-network/netapp-tools/netappdocs/overview

 

and you can also download the latest from the toolchest:

http://mysupport.netapp.com/tools/info/ECMP12505953I.html?productID=62107

 

Thanks,

 

Jason