Subscribe
Accepted Solution

OverProvisioningPercent and TotalLunSize values are "0" ?

Hi all ,

 

When I checked the "OverProvisioningPercent and TotalLunSize" values of "Get-NaEfficiency volume" output  , I see "0"

 

- TotalLunSize:  Total size of all the LUNs contained within this volume.  This value is only valid when the -Recurse switch is present.

- OverProvisioningPercent: The LUN over-provisioning percent of the volume.  This value is equal to (TotalLunSize / Capacity) * 100.  This value is only valid when the -Recurse switch is present.

 

 

volume size is : 4GB (thin)

 

lun1 size is : 10GB (thin)

lun2 size is : 3GB (thick)

 

 

But , "TotalLunSize" and "OverProvisioningPercent" values are "0"

 

 

is it normal ?

 

ontap version : 7.3.7

powershell version : 4.2

 

 

Re: OverProvisioningPercent and TotalLunSize values are "0" ?

Hello @tsener,

 

This is almost certainly because you're using ONTAP 7.3.7, a very old version which is not supported by the PowerShell Toolkit (PSTK).  You might be able to manually calculate the values using the PSTK (I did something similar here), but there's no guarantee any of the cmdlets will work as expected with ONTAP 7.

 

Andrew

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: OverProvisioningPercent and TotalLunSize values are "0" ?

Hi asulliva ,

 

I have tried same commands at ontap 8.2 (7-mode) .But I receive same errors . (value is still "0")

 

 

Re: OverProvisioningPercent and TotalLunSize values are "0" ?

I don't have a 7-mode system to test against at the moment, but, just to be sure, are you using the "-Recurse" option?

 

Get-NaEfficiency -Volume MyVol -Recurse

Andrew

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: OverProvisioningPercent and TotalLunSize values are "0" ?

thank you asulliva