Subscribe
Highlighted
Accepted Solution

PSTK compatibility between version

Hello Community,

 

IHAC which has developped several scripts with NAtoolkitVersion 3.0.0

An old one for its old 8.2 Ontap controller

These controllers will be upgraded to new ones with ONTAP 9.1

So it ask us if all its scripts will still working with ONTAP 9.1?

 

From, my point of view we do not suppress anything between each release of PSTK and, behind that, between each release of API in our SDK.

But only add new cmdlet or add new argument to command.

 

Except the fact that he will certainly need to adapt its script due to network differences between ONTAP 8.2 and ONTAP 9.1, i don't view any problem to upgrade from natoolkit version 3.0.0 to version 4.1.0.0

 

Do you confirml?

 

Outside releases notes, is there any document which synthetizes all additions and eventualy deletion from each version of PSTK and API?

 

TIA

 

Regards

 

Re: PSTK compatibility between version

 

Masson -

 

Most APIs and the PowerShell commandlets will work between versions.

There will be some differences.

 

As you noted, there are the differences in networking between 8.2 and 8.3.

There have been discussions here on the community around these changes and broken PS commandlets.

 

Best practice is to test for API version within scripts and handle for version in the code.

 

There is no comprehensive document I know of the shows changes in APIs between versions.

 

I recommend that client sets up some 9.1 simulators and test their scripts in advance of upgrading.


I hope this response has been helpful to you.

 

At your service,

 

Eugene E. Kashpureff, Sr.
Independent NetApp Consultant http://www.linkedin.com/in/eugenekashpureff
Senior NetApp Instructor, FastLane US http://www.fastlaneus.com/
(P.S. I appreciate 'kudos' on any helpful posts.)