Subscribe

Question about close-nccifssession and maybe a bug

I am getting sporadic wierd results with get-nccifssession and piping it to close-nccifssession.  

 

Half of the time, it works fine, and I checked close-nccifsession and it acceptions pipeline input from sessionID, but the other half of the time, I'm getting errors 

 

 

TerminatingError(Close-NcCifsSession): "Parameter 'SessionId' is mandatory for Data ONTAP 9.0 and up."
close-nccifssession : Parameter 'SessionId' is mandatory for Data ONTAP 9.0 and up.
At C:script.ps1:925 char:62
+ ... {$_.windowsuser -match $user} | close-nccifssession -confirm:$false
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidArgument: (svm1:NcController) [Close-NcCifsSession], ArgumentException
+ FullyQualifiedErrorId : SessionIdRequired,DataONTAP.C.PowerShell.SDK.Cmdlets.Cifs.CloseNcCifsSession

 

Anyone else seeing this? 

 

I'm using 4.3.

Re: Question about close-nccifssession and maybe a bug

Too big to convert I'm afraid: PS C:\WINDOWS\system32> [int64]::MaxValue 9223372036854775807 13404964290887995043 is longer by 1 char and exceeds the range. POwershell is working fine but it seems like the cmdlet has not accounted for the sessionID being longer. One way around it would likely be to use powershell with one of the invoke cmdlets to run the command at the cluster head.