Subscribe
Accepted Solution

SME 6.0 verification creates flex-clones

i'm building out our SME backup solution for EX2010.

SD 6.4

SME 6.0

the mailbox servers are Hyper-v guests using FC Pass-though disks for the databases.

whenever i backup and verify a database it creates and mounts flexclone that remains after the backup and verification completes.

as you cannot remove mount points with snapdrive when using pass-through disks i have to offlline and delete the flexclones on the filer.

is this normal behavior? if i select 'choose a drive letter' in verification settings it does the same thing but assigns it a drive letter.

it is annoying because:

-it is creating busy snapshots

-there are flexclones all over the filer

-after trhe flexclones are removed on the filer, they disappear from within the VM but i have to go into hyper-v manager, into the settings of the VM and remove the mapping to the now 'unreachable' disk - otherwise the snap manager for hyper-v backup of the vm fails.

is this a configuration issue,

any help much appreciated,

thanks

Re: SME 6.0 verification creates flex-clones

There is a bug with SDW 6.4 and Hyper-V pass-through.  You need to use 6.4P1. http://support.netapp.com/NOW/download/software/snapdrive_win/6.4P1/

Re: SME 6.0 verification creates flex-clones

thanks spence.  that looks like it might be the problem! 

i'll deploy when im back in the office tomorrow and post the results!

Re: SME 6.0 verification creates flex-clones

still get the left over mess after upgrading to SDW 6.4P1

it is better now because i can now delete the flexclone mountpoints within SDW and it will delete it from the filer and also doesnt leave anything behind

in the Hyper-V manager settings for the VM (Unreachabe Disk etc)

it just wont do it as part of the verification process in SME.  the gui displays everything was successful (all green ticks) but the report show the below:

[09:21:06.410]  Dismounting LUN [C:\Program Files\NetApp\SnapManager for Exchange\SnapMgrMountPoint\MPDisk001] of Snapshot [exchsnap__xxxxxxxxxxxxxxxxxxxxxxxxxxx]...

[09:21:10.456]  [SnapDrive Error]:The requested operation is not supported.

(SnapDrive Error Code: 0xc0041085)

[09:21:22.359]  [SnapDrive Error]:The requested operation is not supported.

(SnapDrive Error Code: 0xc0041085)

[09:21:22.359]  SnapDrive failed to dismount the snapshot.

[09:21:22.422]  Unknown Error, Error Code: 0xc0041085

[09:21:22.422]  Re-trying to force dismounting LUN...

[09:21:22.438]  [SnapDrive Error]:The LUN may not be connected, because its mount point cannot be found.

(SnapDrive Error Code: 0xc0041085)

[09:21:22.438]  SnapManager will pause 70 seconds after force dismount, please wait...

[09:22:32.422]  SnapDrive failed to dismount the snapshot.

[09:22:32.422]  Unknown Error, Error Code: 0xc0041085

I have logged a support case so will see what Netapp come back with.

thanks

Re: SME 6.0 verification creates flex-clones

Just a belated update on this post.  The issue was resolved with a upgrade of Snapdrive to version 6.4.1