Subscribe

Snapvault Schedules created with Powershell don't update

I've created test snapvault schedules via Ontap and Powershell. The vault schedules configured the old fashioned way kick off according to the schedule. When I create a new schedule for a snapvault via powershell, it runs once and then never again. Is this a problem with the toolkit? Or am I doing something wrong?

Re: Snapvault Schedules created with Powershell don't update

I tried this by setting an hourly snapshot schedule:

PS C:\> Get-NaSnapvaultSecSnapshotSchedule vol0

VolumeName           ScheduleName         Retain DaysOfWeek           HoursOfDay           AutoUpdate Preserve
----------           ------------         ------ ----------           ----------           ---------- --------
vol0                 vol0_sv_sched            25 Mon-Fri              0-23                    True       on

Now (1/5/2011) I'm seeing hourly updates on the secondary from this schedule:

PS C:\> Get-NaSnapshot vol0 vol0_sv_sched*

Name                                               Created      Total Cumulative Dependency
----                                               -------      ----- ---------- ----------
vol0_sv_sched.0                                   1/5/2011     2.4 MB     2.4 MB
vol0_sv_sched.1                                   1/5/2011     2.8 MB     5.8 MB

vol0_sv_sched.10                                12/14/2010     5.9 MB   102.7 MB
vol0_sv_sched.11                                12/13/2010     5.2 MB   109.2 MB
vol0_sv_sched.2                                   1/5/2011     3.0 MB     8.8 MB
vol0_sv_sched.3                                   1/5/2011     3.0 MB    11.8 MB
vol0_sv_sched.4                                   1/5/2011     2.6 MB    15.3 MB
vol0_sv_sched.5                                   1/5/2011     2.6 MB    17.9 MB
vol0_sv_sched.6                                   1/5/2011     2.8 MB    20.7 MB

vol0_sv_sched.7                                 12/15/2010     3.5 MB    75.3 MB
vol0_sv_sched.8                                 12/15/2010     6.8 MB    87.9 MB
vol0_sv_sched.9                                 12/14/2010     4.8 MB    96.8 MB

Did you resolve this?  If not, can you share some of your script?

Snapvault Schedules created with Powershell don't update

I had this problem (I believe) for me it was down to the configuration and explanation of the snapvault setup. It states

"New-NaSnapvault /vol/vol0/svsec dunn /vol/vol0/svpri"

This is a qtree to qtree level snapvault relationship. It appears that if you do not do this this way it excepts the command but adds an extra slash on the source volume and therefore cannot update the relationship. I had this problem because I was doing volume to qtree relationships. for example

"New-NaSnapvault -SecondaryPath "/vol/sv_destinationVol/Qtree1" -PrimarySystem "Filer02" -PrimaryPath "/vol/SourceVol" 

I ended up with

/vol/SourceVol//  Filer01:/vol/sv_destinationVol/Qtree1

after running the snapvault destinations command. Notice the double slash after the SourceVol

I fixed this by adding a slash and hyphen after the volume as instructed when doing this from command line. for example:

"New-NaSnapvault -SecondaryPath "/vol/sv_destinationVol/Qtree1" -PrimarySystem "Filer02" -PrimaryPath "/vol/SourceVol/-"

This made the snapvault relationships look correct and allowed updating.

Hope this helps