Subscribe
Accepted Solution

Some commands aren't working at Ontap version 7.3.7P3

Hi all ,

 

Some commands aren't working at Ontap version 7.3.7P3

 

is it normal ?

 

 

Get-NaVolSpace vol0


Get-NaVolFootprint vol0

 

 

how can I run that commands at ontap version 7.3.7P3 ? or what is the minimum ontap version requirements of the commands ?

 

 

Thank you.

 

Re: Some commands aren't working at Ontap version 7.3.7P3

Hi,

 

 

 

It is not supported in the version (7.3.7 ) of ontap you are using because the Get-NaVolSpace cmdlet uses the API volume-space-list-info-iter-start, next, end ( Please refer to Get-NaCommand ) available only from ontap version 8.2

 

 

 

Thanks,

Nayab

 

 

**** If my reply helped you to resolve your issue, Please help to mark it as solution to help other****

Re: Some commands aren't working at Ontap version 7.3.7P3

Hi NAYABSK ,

 

has it  same problem at "Get-NaVolFootprint" command ?

 

 

Get-NaVolSpace vol0


Get-NaVolFootprint vol0

 

 

is there any documentation about command's supported versions ?

 

how can I find other command's supported ontap versions ?

 

 

 

Thank you.

Re: Some commands aren't working at Ontap version 7.3.7P3

Hi, 

 

May i know the toolkit version you are using ?

 

Thanks,

Nayab

Re: Some commands aren't working at Ontap version 7.3.7P3

Hi NAYABSK ,

 

the powershell toolkit version is 4.2 (latest)

 

 

 

Re: Some commands aren't working at Ontap version 7.3.7P3

HI, 

 

 

Although your toolkit is latest i see your ontap is pretty old version... As per my knowledge 

 

Get-NaVolSpace  &  Get-NaVolFootprint  supports only from Ontap 8.2 version ( I tried these commands in earlier version of ontap 8.1 but didn't work and then i tried it on 8.2 and worked ) So i suggest you to upgrade it to 8.2 7-Mode to make best use to powershell toolkit Smiley Happy 

 

I tried to find documentation on this but it seems difficult because every toolkit release notes has the changes made to that version of powershell but it wouldn't be mentioned on which version of Ontap

 

 

Thanks,

Nayab

 

Re: Some commands aren't working at Ontap version 7.3.7P3

Hi NAYABSK,

 

Thanks for your help